Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585397 - Install mode option "text" Is not offered
Install mode option "text" Is not offered
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 17:18 EDT by Gordan Bobic
Modified: 2010-04-23 18:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 18:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordan Bobic 2010-04-23 17:18:17 EDT
Unlike in previous versions of RHEL, there appears to be no "text install" option offered in the boot menu of RHEL6 beta. However, if "tab" is used to change boot parameters and "askmethod" is replaced by "text", text mode installer does in fact work.

Since a lot of servers don't have a mouse for a graphical install, and/or might be being installed via a serial only text console, this important installation method option should be clearly offered, especially since it is already built in.
Comment 1 Bill Nottingham 2010-04-23 17:21:25 EDT
text mode install is deprecated, and not fully featured; therefore it's not offered as a first-level option.

Using something like VNC is greatly preferred.
Comment 2 Gordan Bobic 2010-04-23 17:59:38 EDT
In that case there needs to be an alternative way to break out to the command line to run fdisk and mkfs manually. This is pretty much impossible in cases such as installing in a VM using virt-manager. Even if there is a shell running on tty 2, there is no way to access it from the graphical install via virt-manager, since pressing Ctrl-Alt-F2 switches to the HOST's VT 2.

Having full manual control over this part of the install process is vital, especially for making sure partitions are aligned properly on SSDs and other media sensitive to it (e.g. disks with non-standard hardware sector sizes), along with any special mkfs options that need to be applied (e.g. mkfs.ext2/3/4 -b 4096 -E stripe-width=32 for SSDs with erase block size of 128KB).
Comment 4 David Cantrell 2010-04-23 18:47:57 EDT
(In reply to comment #2)
> In that case there needs to be an alternative way to break out to the command
> line to run fdisk and mkfs manually. This is pretty much impossible in cases
> such as installing in a VM using virt-manager. Even if there is a shell running
> on tty 2, there is no way to access it from the graphical install via
> virt-manager, since pressing Ctrl-Alt-F2 switches to the HOST's VT 2.

virt-manager's Send Key menu offers the ability to send Ctrl-Alt-Fx to the virt machine rather than the host system.

> Having full manual control over this part of the install process is vital,
> especially for making sure partitions are aligned properly on SSDs and other
> media sensitive to it (e.g. disks with non-standard hardware sector sizes),
> along with any special mkfs options that need to be applied (e.g. mkfs.ext2/3/4
> -b 4096 -E stripe-width=32 for SSDs with erase block size of 128KB).    

For complex setups like this, kickstart is your best bet.  Once you figure out the commands you need to run for a particular installation doing an interactive install, construct a kickstart file and perform the partitioning and formatting in the kickstart's %pre script.  Then use the kickstart "part" commands to assign the newly created partitions to different mount points, making sure to pass the --noformat option.

Note You need to log in before you can comment on or make changes to this bug.