Bug 585406 - No "Custom Layout" partitioning option offered in text mode
No "Custom Layout" partitioning option offered in text mode
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 17:33 EDT by Gordan Bobic
Modified: 2010-04-26 17:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 18:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordan Bobic 2010-04-23 17:33:58 EDT
In RHEL 6 beta, in text install mode (still invokable by manually specifying "text" as a boot parameter by pressing tab), there is no "Custom Layout" partitioning option offered during the installation. This same issue exists in Fedora 12 and Fedora 13. The custom layout option IS offered in the graphical install mode, so it should also be there in text mode.
Comment 2 David Cantrell 2010-04-23 18:42:00 EDT
Text mode installation in RHEL-6 has been greatly simplified and all but deprecated.  Custom partitioning in RHEL-6 is only available via the graphical installer interface (either on physical hardware sitting in front of you or via VNC) or kickstart.  The only partitioning mechanism available during an interactive text mode installation is automatic partitioning.  Note that kickstart gives you full control under either interface, text or graphical.
Comment 3 David Cantrell 2010-04-23 18:43:24 EDT
For reference to the original development plan for simplification of text mode:

    http://fedoraproject.org/wiki/Anaconda/Features/NewTextUI
Comment 4 Gordan Bobic 2010-04-23 19:15:17 EDT
Removing the custom partitioning is arguably a step too far in dumbing down the text installer, though.
Comment 5 David Cantrell 2010-04-26 17:34:23 EDT
(In reply to comment #4)
> Removing the custom partitioning is arguably a step too far in dumbing down the
> text installer, though.    

The problem is maintaining two completely separate code bases for the installer interface.  With the addition of many new storage types for RHEL-6 and the likelihood of people having hundreds or thousands of storage devices, the text mode interface simply doesn't scale.  To do it correctly there would require a completely separate design and we just don't have the resources to maintain two installer interfaces in anaconda.

Again, if you do not want to use or cannot use the graphical installer directly at the console, you can use vnc install mode which gives you the graphical installer -or- you can use kickstart.

Note You need to log in before you can comment on or make changes to this bug.