Bug 585417 - kernel 2.6.34-0.38.rc5.git0.fc14.x86_64 does not boot, snd_hda_intel ??
kernel 2.6.34-0.38.rc5.git0.fc14.x86_64 does not boot, snd_hda_intel ??
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 19:08 EDT by Antonio A. Olivares
Modified: 2010-08-27 02:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-27 02:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file that shows error message (1.09 MB, image/jpeg)
2010-04-23 19:08 EDT, Antonio A. Olivares
no flags Details

  None (edit)
Description Antonio A. Olivares 2010-04-23 19:08:40 EDT
Created attachment 408755 [details]
file that shows error message

Description of problem:  Since older 2.6.34-0.4.rc0.git2.fc14.x86_64, none of the newer kernels have been able to boot, all of them die with the message in the picture(attached).  This is on rawhide.
$ cat /etc/fedora-release 
Fedora release 14 (Rawhide)


I have been trying out the newer kernels, but cannot get past the screen which I will be attaching.  I have been a bit busy and therefore not able to file this bug.  


Version-Release number of selected component (if applicable):
2.6.34-0.38.rc5.git0.fc14.x86_64
This one above and all new kernels after this one:
2.6.34-0.4.rc0.git2.fc14.x86_64

This is the only kernel that works on my machine without the error above.  


How reproducible:
Don't know it happens on this machine only :(  
Here's smoltprofile to see if it would help?
http://www.smolts.org/client/show/pub_8b7db8bc-665b-4e96-a662-2750f5d2adac




Steps to Reproduce:
1.  install newer rawhide kernel(s)
2.  shutdown and restart machine
3.  see the greeting(picture)  
   
Actual results:  kernel does not boot 


Expected results:  that the kernel boot like on other machine that also runs rawhide, but has nvidia chipset happily using noveaux drivers :)  


Additional info:  upon request
Comment 1 Antonio A. Olivares 2010-05-18 23:13:22 EDT
The kernels that followed also do not boot :(  Same message.

kernel-2.6.34-2.fc14
--------------------
* Sun May 16 2010 Kyle McMartin <kyle@redhat.com> 2.6.34-2
- Disable strict copy_from_user checking until lirc is fixed.

* Sun May 16 2010 Kyle McMartin <kyle@redhat.com> 2.6.34-1
- Linux 2.6.34

* Fri May 14 2010 Roland McGrath <roland@redhat.com> 2.6.34-0.56.rc7.git4
- x86: put assembly CFI in .debug_frame

* Thu May 13 2010 Dave Jones <davej@redhat.com>
- 2.6.34-rc7-git4

* Wed May 12 2010 Chuck Ebbert <cebbert@redhat.com>
- Linux 2.6.34-rc7-git3
- Fix up utrace.patch
- Drop autofs-fix-link_count-usage.patch

* Mon May 10 2010 Kyle McMartin <kyle@redhat.com>
- Don't link perf against libbfd.a.

* Mon May 10 2010 Kyle McMartin <kyle@redhat.com>
- fs-explicitly-pass-in-whether-sb-is-pinned-or-not.patch  (rhbz#588930)

* Mon May 10 2010 Kyle McMartin <kyle@redhat.com>
- linux-2.6-input-hid-quirk-egalax.patch: copy from F-13^H2.

Does not boot!  

What should I do?
Comment 2 Yanko Kaneti 2010-05-19 06:00:14 EDT
As I already suggested on the mailing list...
Have you tried booting with pci=nocrs on the kernel command-line ?
Comment 3 Antonio A. Olivares 2010-05-19 06:25:31 EDT
As the last several kernels before 

kernel-2.6.34-2.fc14

Don't work even with that boot parameter.  The only one that booted and still boots is 
2.6.34-0.4.rc0.git2.fc14.x86_64

I have had no choice but to rpm -e kernels > 2.6.34-0.4.rc0.git2.fc14.x86_64

If you have other boot parameters I can try, please let me know.  This one does not help.  Thanks.
Comment 4 Chuck Ebbert 2010-07-19 07:13:30 EDT
Can you get a picture of the entire screen with the error messages? And try turning off the flash on the camera too.
Comment 5 Bug Zapper 2010-07-30 07:27:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.