Bug 585486 - Cannot retrieve repository metadata (repomd.xml) for repository: fedora
Cannot retrieve repository metadata (repomd.xml) for repository: fedora
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 06:31 EDT by Kinshuk Sunil
Modified: 2014-01-21 18:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-24 06:42:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kinshuk Sunil 2010-04-24 06:31:03 EDT
Description of problem:
I was running Fedora 12. Started updating my Fedora 12 install to Fedora 13 Beta as I was told it had better hardware support for my Dell Inspiron 1564 Laptop.

Started following steps mentioned at: https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum

When I reached step 4, since then any yum commands results in the error message:
"Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again"

I have searched the internet for solutions to these issues. Have already tried the following:
1. Switch baseurl and mirrorlist in my fedora.repo and fedora-updates.repo
2. Added Mirror IPs in my /etc/hosts
3. Added a proxy statement inside my yum.conf (since I am under a proxy)

But neither has solved my issue.

Additional info:
Current Yum.conf - http://fpaste.org/ZYNz/
Current Fedora.repo - http://fpaste.org/qLwE/
Actual Yum Output - http://fpaste.org/zHhp/

rpm -q fedora-release: fedora-release-13-0.7.noarch
rpm -q libproxy: libproxy-0.2.3-12.fc12.i686
Comment 1 Kinshuk Sunil 2010-04-24 06:42:13 EDT
added:
proxy=<ip>:<port>
proxy_username=<my username>
proxy_password=<my password>

and yum is working now. hopefully, will update to Fedora 13 Beta seamless now.

Note You need to log in before you can comment on or make changes to this bug.