Bug 585487 - Bluetooth mobile internet broken in this update
Bluetooth mobile internet broken in this update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 06:33 EDT by Zdravko Nikolov
Modified: 2010-04-29 07:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 05:17:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (60.51 KB, image/png)
2010-04-26 06:15 EDT, Zdravko Nikolov
no flags Details

  None (edit)
Description Zdravko Nikolov 2010-04-24 06:33:43 EDT
Description of problem:


Version-Release number of selected component (if applicable):

ModemManager-0.3-9.git20100409.fc12.i686
NetworkManager-0.8.0-6.git20100408.fc12.i686

How reproducible:

Always

Steps to Reproduce:
1. Connect to a bluetooth dun dial-up network service on a gsm phone using blueman

  
Actual results:

Blueman displays a message that the modem connection is available via NetworkManager but no Wireless Modem connection is available in NM

Expected results:

The connection should be available in NM an it should be able to connect.

Additional info:

This worked perfect before the update of NM and ModemManager
Comment 1 Dan Williams 2010-04-25 02:22:41 EDT
NetworkManager includes built-in Bluetooth DUN support.  You'll want to set up a DUN connection via the bluetooth icon's "Set up new device..." wizard.

After you've completed that step, if the connection does not appear in the NM menu, we'll want to grab some logs to figure out what's going on.
Comment 2 Zdravko Nikolov 2010-04-25 08:59:48 EDT
I have done exactly that but no device shows up in NM. As I said it worked fine prior to the update (also reverting back to previous NM and MM made it work again..)

Below is the log..

Apr 25 13:49:35 X41 bluetoothd[2339]: link_key_request (sba=00:14:A4:DC:38:D6, dba=34:7E:39:5B:B1:08)
Apr 25 13:49:35 X41 bluetoothd[2339]: pin_code_request (sba=00:14:A4:DC:38:D6, dba=34:7E:39:5B:B1:08)
Apr 25 13:49:46 X41 bluetoothd[2339]: link_key_notify (sba=00:14:A4:DC:38:D6, dba=34:7E:39:5B:B1:08, type=0)
Apr 25 13:49:46 X41 dbus-daemon: Rejected send message, 2 matched rules; type="method_return", sender=":1.69" (uid=500 pid=2362 comm="/usr/bin/python) interface="(unset)" member="(unset)" error name="(unset)" requested_reply=0 destination=":1.64" (uid=0 pid=2338 comm="/usr/sbin/bluetoothd))
Apr 25 13:49:46 X41 bluetoothd[2339]: probe failed with driver input-headset for device /org/bluez/2338/hci0/dev_34_7E_39_5B_B1_08
Apr 25 13:49:50 X41 bluetoothd[2339]: link_key_request (sba=00:14:A4:DC:38:D6, dba=34:7E:39:5B:B1:08)
Apr 25 13:49:50 X41 modem-manager: (rfcomm0) opening serial device...
Apr 25 13:49:51 X41 modem-manager: (rfcomm0) closing serial device...
Apr 25 13:49:51 X41 modem-manager: Generic: (tty/rfcomm0) WARNING: missing udev 'device' file
Apr 25 13:49:51 X41 modem-manager: (rfcomm0) opening serial device...
Apr 25 13:49:51 X41 modem-manager: (Generic): GSM modem /sys/devices/pci0000:00/0000:00:1d.2/usb4/4-1 claimed port rfcomm0
Apr 25 13:49:51 X41 modem-manager: (rfcomm0) closing serial device...
Apr 25 13:49:51 X41 NetworkManager: <info> ignoring modem 'rfcomm0' (no associated Bluetooth device)
Comment 3 Dan Williams 2010-04-26 02:08:53 EDT
Ok, this shows that ModemManager is finding the modem correctly, but the configuration that NM requires (that the bluetooth wizard is supposed to write to GConf) somehow isn't getting set correctly.

Any chance you can take a screenshot of the applet menu for me after you've completed the bluetooth wizard?  And you are using the gnome-bluetooth icon to set up the device, *not* blueman, correct?
Comment 4 Zdravko Nikolov 2010-04-26 06:15:13 EDT
Created attachment 409128 [details]
Screenshot

I am using only blueman..A screenshot is attached..
Comment 5 Dan Williams 2010-04-26 18:32:35 EDT
You're going to need to use the gnome-bluetooth applet, not blueman.  I have no idea what blueman is doing underneath, but it's not really a supported way to interact with NetworkManager.  NM has the functionality that you're looking for, so if there's a problem with NM or nm-applet's handling of DUN, then we can try to fix this bug.

But otherwise, it's a blueman bug.  The nm-applet GConf data is an implementation detail that's not public API, and that's what blueman is modifying.  The NM gnome-bluetooth plugin is the supported way of configuring PAN and DUN connections.

See:

http://blogs.gnome.org/dcbw/2009/07/10/unwire-with-networkmanager/

If that procedure fails to work, then we can investigate the issue.  Otherwise, if that procedure does work, then it's a Blueman bug.
Comment 6 Zdravko Nikolov 2010-04-27 05:17:21 EDT
The connection with gnome-bluetooth works (I will contact the developers of blueman). Having said that, gnome-bluetooth's functionality is a joke compared to blueman. It should be replaced by blueman.
Comment 7 Bastien Nocera 2010-04-28 11:04:46 EDT
(In reply to comment #6)
> The connection with gnome-bluetooth works (I will contact the developers of
> blueman). Having said that, gnome-bluetooth's functionality is a joke compared
> to blueman. It should be replaced by blueman.    

Apart from the jibe at gnome-bluetooth, file bugs against gnome-bluetooth upstream (http://bugzilla.gnome.org) if you're missing specific functionality in gnome-bluetooth.
Comment 8 Zdravko Nikolov 2010-04-29 07:48:07 EDT
Bastien, my comment was not intended as a jibe...my appologies..

I do install many desktops for normal users.. and what they want is functionality and now..no matter what is providing it..The concept of filing a bug in order to receive this functionality is an alien one to them and is not likely to happen. After all, the main goal is to make linux/gnome popular, at least this is how I see it...

Note You need to log in before you can comment on or make changes to this bug.