Bug 585496 - miro fails to do handle feed http://krampf.blip.tv/rss (updating, removing, anything...)
Summary: miro fails to do handle feed http://krampf.blip.tv/rss (updating, removing, a...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-24 11:17 UTC by Till Maas
Modified: 2010-05-09 19:44 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-05-09 09:49:25 UTC


Attachments (Terms of Use)

Description Till Maas 2010-04-24 11:17:36 UTC
Description of problem:
Everytime I start miro, it reports a bug. It seems to occur when it tries to update http://krampf.blip.tv/rss, but it also happens when I try to remove this feed.

Version-Release number of selected component (if applicable):
Miro-2.5.4-3.fc12

How reproducible:
always

Steps to Reproduce:
1. Just start Miro with this feed added. I added it a long time ago and back then it worked.
  
Actual results:
Miro does not update the feed or allows to remove the feed. There are backtraces on stdout or stderr:

2010-04-24 13:08:56,441 INFO     ----- CRASH REPORT (DANGER CAN HAPPEN) -----
2010-04-24 13:08:56,442 INFO     App:        Miro
Publisher:  Participatory Culture Foundation
Platform:   gtk-x11
Python:     2.6.2 (r262:71600, Jan 25 2010, 18:46:47)  [GCC 4.4.2 20091222 (Red Hat 4.4.2-20)]
Py Path:    ['/usr/bin', '/usr/lib64/python26.zip', '/usr/lib64/python2.6', '/usr/lib64/python2.6/plat-linux2', '/usr/lib64/python2.6/lib-tk', '/usr/lib64/python2.6/lib-old', '/usr/lib64/python2.6/lib-dynload', '/usr/lib64/python2.6/site-packages', '/usr/lib64/python2.6/site-packages/PIL', '/usr/lib64/python2.6/site-packages/gst-0.10', '/usr/lib64/python2.6/site-packages/gtk-2.0', '/usr/lib64/python2.6/site-packages/webkit-1.0', '/usr/lib/python2.6/site-packages']
Version:    2.5.4
Serial:     20091202000
Revision:   ssh://wguaraldi@pcf1.pculture.org/var/git/miro - 1e20db82
Builder:    mockbuild@xb-01.phx2.fedoraproject.org
Build Time: 1269955663.01
Time:       Sat Apr 24 13:08:56 2010
When:       While handling idle (Thread Pool Callback (Feedparser callback - http://krampf.blip.tv/rss))

Exception
---------
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/miro/trapcall.py", line 42, in trap_call
    function(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/miro/feed.py", line 1566, in feedparser_callback
    old_items = self.createItemsForParsed(parsed)
  File "/usr/lib64/python2.6/site-packages/miro/feed.py", line 1376, in createItemsForParsed
    for item in self.items:
  File "/usr/lib64/python2.6/site-packages/miro/storedatabase.py", line 382, in query
    for id in self.query_ids(klass, where, values, order_by, joins):
  File "/usr/lib64/python2.6/site-packages/miro/storedatabase.py", line 400, in query_ids
    self._restore_objects(schema, unrestored_ids)
  File "/usr/lib64/python2.6/site-packages/miro/storedatabase.py", line 423, in _restore_objects
    for row in self.cursor.fetchall():
OperationalError: Could not decode to UTF-8 column 'feedparser_output' with text '{'blip_userid': u'99451', 'blip_language': u'English', 'blip_thumbnail_src': u'RobertKrampf-IsThatAColorPhoto840-540.jpg', 'blip_posts

Call stack
----------
  File "/usr/lib64/python2.6/site-packages/miro/trapcall.py", line 47, in trap_call
    signals.system.failed_exn(when)


Expected results:
It should just work, update the feed and allow me to remove it.

Additional info:
Is there any chance that this will be fixed? Or is this maybe fixed in Miro 3? Will there be Miro 3 for F12?

Comment 1 Alex Lancaster 2010-04-24 17:35:38 UTC
Seems to work OK with my local Miro 3.0 build.  I'll look into pushing the 3.0 to F-12, which I was going to do fairly soon to updates-testing anyway.

Comment 2 Alex Lancaster 2010-04-24 17:37:19 UTC
Interestingly, I couldn't seem to add the site to miro just using "Add Feed" from the menu and supplying the URL, but it worked when I added by searching for krampf in the Miro Guide and then clicking the "Add Feed" button.

Comment 3 Till Maas 2010-05-09 09:27:54 UTC
This is fixed in Miro-3.0.1-1.fc12

Comment 4 Michel Alexandre Salim 2010-05-09 09:49:25 UTC
Thanks for reporting! Closing as NEXTRELEASE since the Miro update is already pushed to testing.

Comment 5 Till Maas 2010-05-09 11:42:53 UTC
(In reply to comment #4)
> Thanks for reporting! Closing as NEXTRELEASE since the Miro update is already
> pushed to testing.    

Afaik you can still edit the update and add this bug to the list of fixed bugs.

Comment 6 Michel Alexandre Salim 2010-05-09 19:44:45 UTC
ISTR doing that resets the bug to "pending" -- I might be mistaken, but I don't want to risk having that happen.


Note You need to log in before you can comment on or make changes to this bug.