Bug 585524 - SELinux is preventing /bin/mkdir "write" access on /root.
SELinux is preventing /bin/mkdir "write" access on /root.
Status: CLOSED DUPLICATE of bug 543970
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:0ec76a0d02e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 10:04 EDT by Benjamin Kahn
Modified: 2010-04-26 04:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 04:53:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 2010-04-24 10:04:39 EDT
Summary:

SELinux is preventing /bin/mkdir "write" access on /root.

Detailed Description:

SELinux denied access requested by mkdir. It is not expected that this access is
required by mkdir and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root [ dir ]
Source                        mkdir
Source Path                   /bin/mkdir
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-7.6-9.fc12
Target RPM Packages           filesystem-2.4.30-2.fc12
Policy RPM                    selinux-policy-3.6.32-110.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.x86_64 #1 SMP
                              Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sat 24 Apr 2010 10:03:14 AM EDT
Last Seen                     Sat 24 Apr 2010 10:03:14 AM EDT
Local ID                      68aae46b-ef29-422c-a489-14b30028ed65
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1272117794.144:8): avc:  denied  { write } for  pid=1778 comm="mkdir" name="root" dev=dm-0 ino=81922 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1272117794.144:8): arch=c000003e syscall=83 success=no exit=-13 a0=7fff63e93d89 a1=1ed a2=7fff63e92930 a3=7fff63e92480 items=0 ppid=1774 pid=1778 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="mkdir" exe="/bin/mkdir" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,mkdir,xdm_t,admin_home_t,dir,write
audit2allow suggests:

#============= xdm_t ==============
#!!!! The source type 'xdm_t' can write to a 'dir' of the following types:
# xkb_var_lib_t, var_lock_t, xdm_rw_etc_t, root_t, tmp_t, var_t, user_fonts_t, user_tmpfs_t, xdm_spool_t, fonts_cache_t, user_home_dir_t, locale_t, var_auth_t, tmpfs_t, var_spool_t, user_tmp_t, var_lib_t, var_run_t, auth_cache_t, xdm_tmpfs_t, xdm_tmp_t, xserver_log_t, var_log_t, xdm_log_t, pam_var_run_t, xdm_var_lib_t, xdm_var_run_t, xdm_home_t, pam_var_console_t, pcscd_var_run_t, root_t, nfs_t

allow xdm_t admin_home_t:dir write;
Comment 1 Miroslav Grepl 2010-04-26 04:53:46 EDT
Are you attempting to login in as root? 

This is not allowed by SELinux.

*** This bug has been marked as a duplicate of bug 543970 ***

Note You need to log in before you can comment on or make changes to this bug.