Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 585525 - RFE: Include btrfs compression option in Anaconda installed
Summary: RFE: Include btrfs compression option in Anaconda installed
Keywords:
Status: CLOSED DUPLICATE of bug 1082085
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-24 14:05 UTC by Valent Turkovic
Modified: 2015-04-14 16:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-13 16:31:11 UTC
Type: ---


Attachments (Terms of Use)

Description Valent Turkovic 2010-04-24 14:05:25 UTC
Description of problem:
Please include option to enable compression on btrfs partitions.
something that would mount partition with compress option: 
mount -o compress /dev/sdax
 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chris Lumens 2010-04-30 14:17:56 UTC
anaconda does not provide full options even for the filesystems that we do fully support.  btrfs is still listed as experimental in anaconda and even when it's really supported, we're unlikely to include a checkbox for its many options.

Comment 2 Gene Czarcinski 2013-12-16 05:36:31 UTC
Time passes.  Please reconsider adding a compression option for BTRFS.  If a single compression method most be specified, then choose lzo.  The resaon for using compression these days is to improve performance rather than saving disk space.  This needs to include adding the option to /etc/fstab on a per-subvol basis as well as adding it to the mounts anaconda makes.

Comment 3 Tonic Artos 2014-06-13 09:57:28 UTC
An easy solution that would make everybody happy is to have a text entry field for entering mount options.

Comment 4 David Shea 2015-04-13 16:31:11 UTC
The anaconda GUI is still not going to provide a means to configure every aspect of every filesystem. Duping to 1082085 for the kickstart side of btrfs configuration.

*** This bug has been marked as a duplicate of bug 1082085 ***

Comment 5 David Lehman 2015-04-14 16:48:50 UTC
We are going to be spending little or no time on development specific to btrfs in the near future. We have more pressing matters to attend to. You are welcome to submit patches, of course.


Note You need to log in before you can comment on or make changes to this bug.