Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 585526 - Missing dependency (port)midi for pygame
Summary: Missing dependency (port)midi for pygame
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pygame
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Kaluža
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-24 14:07 UTC by Daniel Sjoholm
Modified: 2017-04-19 09:23 UTC (History)
5 users (show)

Fixed In Version: pygame-1.9.1-3.fc14 pygame-1.9.3-1.fc26 pygame-1.9.3-1.fc24 pygame-1.9.3-1.fc25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-14 17:20:28 UTC
Type: ---


Attachments (Terms of Use)

Description Daniel Sjoholm 2010-04-24 14:07:12 UTC
Description of problem:
Pygame 1.9.X versions have midi support, but it's not available in fedora12 due to lack of build-dependency for portmidi, and thus midi support isn't built.

Version-Release number of selected component (if applicable):
pygame-1.9.1-1.fc12.i686

How reproducible:
Always

Steps to Reproduce:
1. python -m pygame.examples.midi --list
2.
3.
  
Actual results:
No midi functionality

Expected results:
python -m pygame.examples.midi --list
to return a list of midi interfaces currently available.

Additional info:
Python error shown: ImportError: No module named pypm
Arch bug for it: http://bugs.archlinux.org/task/15847

Comment 1 Per Sjoholm 2010-05-11 09:06:41 UTC
From pygame-1.9.1release 
rpmbuild -bb pygame.spec
.....
WARNING: "smpeg-config" failed!
SDL     : found 1.2.13
FONT    : found
IMAGE   : found
MIXER   : found
SMPEG   : not found
PNG     : found
JPEG    : found
SCRAP   : found
PORTMIDI: not found
PORTTIME: not found
....

Comment 2 Fedora Admin XMLRPC Client 2010-08-12 07:26:00 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Fedora Update System 2010-08-13 09:01:51 UTC
pygame-1.9.1-3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/pygame-1.9.1-3.fc14

Comment 4 Fedora Update System 2010-10-13 12:48:31 UTC
pygame-1.9.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Martin Tarenskeen 2016-04-30 05:56:38 UTC
It looks like the problem has come back:

Version-Release number of selected component (if applicable):
pygame-1.9.1-19.fc23.20150926.x86_64

How reproducible:
Always

Steps to Reproduce:
1. python -m pygame.examples.midi --list
2.
3.
  
Actual results:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib64/python2.7/site-packages/pygame/examples/midi.py", line 820, in <module>
    print_device_info()
  File "/usr/lib64/python2.7/site-packages/pygame/examples/midi.py", line 25, in print_device_info
    pygame.midi.init()
  File "/usr/lib64/python2.7/site-packages/pygame/midi.py", line 71, in init
    import pygame.pypm
ImportError: No module named pypm

Expected results:
python -m pygame.examples.midi --list
to return a list of midi interfaces currently available.

Comment 6 Valentin Villenave 2017-03-14 08:28:40 UTC
It does appear that this bug needs to be reopened (possibly as a new page): I can verify it on Fedora 25, with both python2.7 and python3.5.

Comment 7 Wade Mealing 2017-03-21 09:29:16 UTC
Confirming Valentins comment, reopening.  If maintainer wants new bug he can close and let us know.


Version:

pygame-1.9.1-22.fc25.20150926.x86_64
python-portmidi-217-15.fc25.x86_64

>>> midi
<module 'pygame.midi' from '/usr/lib64/python2.7/site-packages/pygame/midi.pyc'>
>>> dir(midi)
['Input', 'MIDIIN', 'MIDIOUT', 'MidiException', 'Output', '__all__', '__builtins__', '__doc__', '__file__', '__name__', '__package__', '__theclasses__', '_check_init', '_init', '_pypm', 'atexit', 'get_count', 'get_default_input_id', 'get_default_output_id', 'get_device_info', 'init', 'midis2events', 'pygame', 'quit', 'time']

>>> midi.init()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/pygame/midi.py", line 71, in init
    import pygame.pypm
ImportError: No module named pypm
>>> 

As you can see the packages are installed.

I have rebuilt the packages the spec file finds the portmidi devel that is installed, it however does -not- package up the pypm shared libs, importables.

It looks as though from the setup file:

  pypm src/pypm.c $(SDL) $(PORTMIDI) $(PORTTIME) $(DEBUG)


pypm requires PORTTIME which is not found at compile time.

[wmealing@linux pygame-20150926]$ ./configure
./configure
Using UNIX configuration...


Hunting dependencies...
sh: smpeg-config: command not found
sh: smpeg-config: command not found
sh: smpeg-config: command not found
WARNING: "smpeg-config" failed!
SDL     : found 1.2.15
FONT    : found
IMAGE   : found
MIXER   : found
SMPEG   : not found
PNG     : found
JPEG    : found
SCRAP   : found
PORTMIDI: found
PORTTIME: not found
AVFORMAT: not found
SWSCALE : not found
FREETYPE: found 2.6.5

The spec file eludes to porttime being part of libportmidi, I have the devel packages installed, its still not working.   

In the current configuation I think the build configuration is not including the modules because it believes porttime is not found.

I leave this now up to the package maintainer to determine what the next steps are.

Thanks !

Comment 8 Fedora Update System 2017-04-10 15:22:02 UTC
pygame-1.9.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0b76ab3fe5

Comment 9 Fedora Update System 2017-04-10 15:22:26 UTC
pygame-1.9.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d8dac0fcb

Comment 10 Fedora Update System 2017-04-10 15:22:38 UTC
pygame-1.9.3-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a91941fa47

Comment 11 Fedora Update System 2017-04-10 22:23:01 UTC
pygame-1.9.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0b76ab3fe5

Comment 12 Fedora Update System 2017-04-10 22:57:30 UTC
pygame-1.9.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6d8dac0fcb

Comment 13 Fedora Update System 2017-04-11 00:27:00 UTC
pygame-1.9.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a91941fa47

Comment 14 Fedora Update System 2017-04-14 17:20:28 UTC
pygame-1.9.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2017-04-18 16:49:10 UTC
pygame-1.9.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-04-19 09:23:45 UTC
pygame-1.9.3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.