Bug 585527 - 3 minute hang during boot in "udevadm settle"
Summary: 3 minute hang during boot in "udevadm settle"
Status: CLOSED DUPLICATE of bug 569019
Alias: None
Product: Fedora
Classification: Fedora
Component: mdadm   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-24 14:15 UTC by Tomasz Torcz
Modified: 2010-04-26 17:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 17:20:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomasz Torcz 2010-04-24 14:15:32 UTC
Description of problem:
My F13 system hangs for 180 seconds during the boot, with following messages:

Key slot 0 unlocked.
                Welcome to Fedora 
                Press 'I' to enter interactive startup.
Starting udev: udevd[546]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:3

udevd[546]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:3

udevd[546]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:5


udevadm settle - timeout of 180 seconds reached, the event queue contains:
  /sys/devices/virtual/block/md127 (3930)
Wait timeout. Will continue in the background.  [FAILED]

Setting hostname mother.pipebreaker.pl:         [  OK  ]
Setting up Logical Volume Management:   No volume groups found
        [  OK  ]
Checking filesystems
homeRAID: clean, 1392567/183148544 files, 415176890/732571231 blocks
bootpart: clean, 45/125184 files, 50612/500015 blocks
        [  OK  ]
Remounting root filesystem in read-write mode:          [  OK  ]
Mounting local filesystems:     [  OK  ]
Enabling local filesystem quotas:       [  OK  ]


My system has 5 disks: one for /boot (sda1), four for mdraid5 (sdb÷e, without partitions). Resulting md-device is dm-crypted, and contains / with ext4.

Version-Release number of selected component (if applicable):
2.6.33.2-41.fc13.i686.PAE
udev-151-8.fc13.i686
dracut-005-2.fc13.noarch
mdadm-3.1.1-0.gcd9a8b5.3.fc12.i686


How reproducible:
Always.

Steps to Reproduce:
1. Reboot system
2. Observe 3 minute wait during "Starting udev:"
3. System continue to boot (sucesfully)
  
Actual results:
180 seconds delay.

Expected results:
Faster boot.

Comment 1 Doug Ledford 2010-04-26 17:20:29 UTC

*** This bug has been marked as a duplicate of bug 569019 ***


Note You need to log in before you can comment on or make changes to this bug.