Bug 585537 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
[abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox wa...
Status: CLOSED DUPLICATE of bug 565211
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:03c9aa9fff1d62f0008d5006362...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 11:54 EDT by Giovanni Conconi
Modified: 2010-04-30 23:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 23:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (29.98 KB, text/plain)
2010-04-24 11:55 EDT, Giovanni Conconi
no flags Details

  None (edit)
Description Giovanni Conconi 2010-04-24 11:54:53 EDT
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5/firefox
component: firefox
executable: /usr/lib/firefox-3.5/firefox
kernel: 2.6.32.11-99.fc12.i686
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Put PC in standby mode (with FF open)
2. Wake it up a couple of minutes later
3. FF immediately crashes
Comment 1 Giovanni Conconi 2010-04-24 11:55:49 EDT
Created attachment 408842 [details]
File: backtrace
Comment 2 Giovanni Conconi 2010-04-24 11:56:24 EDT

How to reproduce
-----
1. Put PC in standby mode (with FF open)
2. Wake it up a couple of minutes later
3. FF immediately crashes
Comment 3 Giovanni Conconi 2010-04-24 12:00:09 EDT
(In reply to comment #2)
> 
> How to reproduce
> -----
> 1. Put PC in standby mode (with FF open)
> 2. Wake it up a couple of minutes later
> 3. FF immediately crashes    

I'm sorry, obviously it's the same bug (with the same backtrace). Abrt gave me an error message so I re-report it to be sure it was correctly reported.
Comment 4 Chris Campbell 2010-04-30 23:44:46 EDT
#3  <signal handler called>
No symbol table info available.
#4  0x028ae585 in _releaseobject (npobj=0xab9f0700) at nsNPAPIPlugin.cpp:1555
        refCnt = <value optimized out>
#5  0x028c39c9 in NPObjWrapper_Finalize (cx=0x9d6c8400, obj=0xab832ec0)
    at nsJSNPRuntime.cpp:1601
        npobj = 0xab9f0700
#6  0x05fe6c86 in js_FinalizeObject (cx=0x9d6c8400, obj=0xab832ec0)
    at jsobj.cpp:3417
No locals.
#7  0x05fcb379 in js_GC (cx=0x9d6c8400, gckind=<value optimized out>)
    at jsgc.cpp:3585
        keepAtoms = 0
        i = <value optimized out>
        trc = {context = 0x9d6c8400, callback = 0}
        a = 0xab832ff0
        emptyArenas = 0xab853ff0
        arenaList = 0xc8c11b10
        allClear = 1
        callback = <value optimized out>
        thing = 0xab832ec0
        requestDebit = <value optimized out>
        rt = 0xb7171000
        type = <value optimized out>
        thingSize = 32
        flags = <value optimized out>
        freeList = 0xab832ee0
        ap = 0xab589ff4
        flagp = 
    0xab832f79 ' ' <repeats 119 times>, "4\020\027\267\360\237\200\253"
#8  0x05fa4b02 in JS_GC (cx=0x9d6c8400) at jsapi.cpp:2459
No locals.
#9  0x021b00eb in nsXPConnect::Collect (this=0xb74f2d30)
    at nsXPConnect.cpp:477
        cycleCollectionContext = {<nsAXPCNativeCallContext> = {
            _vptr.nsAXPCNativeCallContext = 0x31b6a38}, mState = 
    HAVE_CONTEXT, mXPC = 0xb74f2d30, mThreadData = 0xb74f4fd0, mXPCContext = 
    0x9d630880, mJSContext = 0x9d6c8400, mContextPopRequired = 1, 
          mDestroyJSContextInDestructor = 0, mCallerLanguage = LANG_NATIVE, 
          mPrevCallerLanguage = LANG_UNKNOWN, mPrevCallContext = 0x0, 
          mOperandJSObject = 0x2ab7f14, mCurrentJSObject = 0xbfe3abac, 
          mFlattenedJSObject = 0x2a14743, mWrapper = 0x32730a4, mTearOff = 
    0xbfe3ab88, mScriptableInfo = 0x2a147b1, mSet = 0x2ab7bce, mInterface = 
    0x2ab7f14, mMember = 0xbfe3abb8, mName = 44121764, mStaticMemberIsLocal = 
    -1075598324, mArgc = 0, mArgv = 0x8000ffff, mRetVal = 0x8000ffff, 
          mReturnValueWasSet = -1075582248, mMethodIndex = 19844, mCallee = 
    0x0, mStringWrapperData = 
    "\316{\253\002\304P\000\001@P^\267\000\000\000\000\000\000\000\000\n\000\000\000\f\254\343\277\000\000\000"}
        cx = 0x9d6c8400
#10 0x02a561b4 in nsCycleCollector::Collect (this=0xb740e000, aTryCollections=
    5) at nsCycleCollector.cpp:2389
        collected = <value optimized out>
        obs = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        whiteNodes = {<nsTPtrArray<PtrInfo>> = {<nsTArray<PtrInfo*>> = 
    {<nsTArray_base> = {static sEmptyHdr = {mLength = 0, mCapacity = 0, 
                  mIsAutoArray = 0}, mHdr = 
    0xa3408000}, <No data fields>}, <No data fields>}, mAutoBuf = 
    "\000\000\000\000\240\017\000\200\315\232\374\005\330\352\343\277\200({\260\214\254\343\277\214\254\343\277\330\352\343\277\030+\362\263\002\000\000\000\000\020\027\267\347\253s\000D\bP\243\207\232\374\005<\213\t\006\200({\260\000\204l\235\250\254\343\277Z\236\374\005\330\352\343\277\200({\260\000\000\000\000\000/{\260\330\352\343\277(\300\343\261\377\237\360\263\000\020\027\267\330\352\343\277,\300\343\261\330\352\343\277@\373y\260\000\b\000\000@P^\267\312\234\374\005<\213\t\006\r\000\000\000\340Wz\260\b\255\343\277v7\376\005\330\352\343\277\340\232\360\263\000\000\000\000\200\244\t\006@\361z\260\000\000\000\000\b\255\343\277A2\000\000\330\352\343\277\240\311\364\263w\213\372\005<\213\t\006\200%{\260\000\204l\235\016\000\000\000$\000\000\000\330\352\343\277\200%{\260\335\065\376\005<\213\t\006\340Wz\260\000\204l\235H\255\343\277\315\232\374\005\330\352\343\277\340Wz\260|\255\343\277|\255\343\277p\354=\261\330\352\343\277H\255\343\277\233-\001\006\330\352\343\277x\307\357\263\207\232\374\005<\213\t\006\340Wz\260\000\204l\235\230\255\343\277Z\236\374\005\330\352\343\277\340Wz\260\000\000\000\000\000_z\260l-\001\006<\213\t\006\377\317\364\263\000\020\027\267\001\000\000\000\340*{\260\330\255\343\277v7\376\005\330\352\343\277\240\311\364\263\312\234\374\005<\213\t\006 +{\260\000\000\000\000\330\255\343\277\027\214\372\005\330\352\343\277\240\311\364\263\000\000\000\000 \000\000\000\000\000@\242\001\000\000\000\005\000\000\000\a\000\000\000\000\306"...}
        totalCollections = 0
#11 0x02a56341 in nsCycleCollector::Shutdown (this=0xb740e000)
    at nsCycleCollector.cpp:2608
No locals.
#12 0x02a56373 in nsCycleCollector_shutdown () at nsCycleCollector.cpp:3082
No locals.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Chris Campbell 2010-04-30 23:53:22 EDT
Thank you for taking the time to submit this bug report.


This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 565211 ***

Note You need to log in before you can comment on or make changes to this bug.