Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585540 - Anaconda GUI freezes (preupgrade)
Anaconda GUI freezes (preupgrade)
Status: CLOSED DUPLICATE of bug 585621
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
13
i686 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 12:21 EDT by Ray Van Dolson
Modified: 2010-04-27 21:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 21:37:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Van Dolson 2010-04-24 12:21:46 EDT
Description of problem:
Dell Latitude D620 running Fedora 11.  Ran preupgrade and rebooted into the installer.  Goes through TUI stuff fine, but as soon as the first GUI screen appears, everything is frozen and I have to hard reset.

Have dual LCD's plugged into this docked laptop, so I tried passing "vga=ask nomodeset" and chose 80x25 text instead of whatever mode it was auto-detecting originally.

Same results and cannot continue with the install/upgrade.

I will try with only one LCD attached to see if this is somehow to blame.

Version-Release number of selected component (if applicable):
anaconda included with Fedora 13 Beta (as retrieved by preupgrade)

How reproducible:
Always

Steps to Reproduce:
1. Get identical hardware to Ray
2. Install Fedora 11 and patch.
3. Run preupgrade and reboot
  
Actual results:
Freeze at first GUI screen.

Expected results:
Installer functions.

Additional info:
In my Fedora 11 environment I was using the nVidia driver from rpmfusion.

The video chipset is an nVidia G27M (Quandro NVS 110M/GeForceGo 7300)
Comment 1 Ray Van Dolson 2010-04-24 12:47:09 EDT
Single head didn't make a difference.  Am trying now with the laptop undocked.

(FYI, this is the 32-bit version of Fedora 13).
Comment 2 Ray Van Dolson 2010-04-24 13:00:36 EDT
Froze undocked as well.  Trying with noacpi noapic now.
Comment 3 Ray Van Dolson 2010-04-24 13:23:08 EDT
No go there either.  At this point I am stumped.  Guess I'll try downloading the actual DVD to see if Anaconda gives problems there (theoretically it should).
Comment 4 Chris Lumens 2010-04-24 22:20:06 EDT
Well, chances are it's not anaconda giving the problem, as anaconda cannot lock the screen like this.  It's more likely X or the kernel at fault here.
Comment 5 Ray Van Dolson 2010-04-26 11:39:18 EDT
I ended up downloading the Net Install DVD and passed the preupgrade boot parameters to it.  This worked fine.

I guess it was probably something in the preupgrade initrd/vmlinuz environment that was fixed on the netinst image.

Probably makes sense to close this out as I can no longer reproduce the issue (upgrade worked via netinst) unless someone else is having this problem or it rings a bell to one of the developers.
Comment 6 Chris Lumens 2010-04-27 21:37:53 EDT

*** This bug has been marked as a duplicate of bug 585621 ***

Note You need to log in before you can comment on or make changes to this bug.