Bug 585540 - Anaconda GUI freezes (preupgrade)
Summary: Anaconda GUI freezes (preupgrade)
Status: CLOSED DUPLICATE of bug 585621
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 13
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-24 16:21 UTC by Ray Van Dolson
Modified: 2010-04-28 01:37 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-04-28 01:37:53 UTC


Attachments (Terms of Use)

Description Ray Van Dolson 2010-04-24 16:21:46 UTC
Description of problem:
Dell Latitude D620 running Fedora 11.  Ran preupgrade and rebooted into the installer.  Goes through TUI stuff fine, but as soon as the first GUI screen appears, everything is frozen and I have to hard reset.

Have dual LCD's plugged into this docked laptop, so I tried passing "vga=ask nomodeset" and chose 80x25 text instead of whatever mode it was auto-detecting originally.

Same results and cannot continue with the install/upgrade.

I will try with only one LCD attached to see if this is somehow to blame.

Version-Release number of selected component (if applicable):
anaconda included with Fedora 13 Beta (as retrieved by preupgrade)

How reproducible:
Always

Steps to Reproduce:
1. Get identical hardware to Ray
2. Install Fedora 11 and patch.
3. Run preupgrade and reboot
  
Actual results:
Freeze at first GUI screen.

Expected results:
Installer functions.

Additional info:
In my Fedora 11 environment I was using the nVidia driver from rpmfusion.

The video chipset is an nVidia G27M (Quandro NVS 110M/GeForceGo 7300)

Comment 1 Ray Van Dolson 2010-04-24 16:47:09 UTC
Single head didn't make a difference.  Am trying now with the laptop undocked.

(FYI, this is the 32-bit version of Fedora 13).

Comment 2 Ray Van Dolson 2010-04-24 17:00:36 UTC
Froze undocked as well.  Trying with noacpi noapic now.

Comment 3 Ray Van Dolson 2010-04-24 17:23:08 UTC
No go there either.  At this point I am stumped.  Guess I'll try downloading the actual DVD to see if Anaconda gives problems there (theoretically it should).

Comment 4 Chris Lumens 2010-04-25 02:20:06 UTC
Well, chances are it's not anaconda giving the problem, as anaconda cannot lock the screen like this.  It's more likely X or the kernel at fault here.

Comment 5 Ray Van Dolson 2010-04-26 15:39:18 UTC
I ended up downloading the Net Install DVD and passed the preupgrade boot parameters to it.  This worked fine.

I guess it was probably something in the preupgrade initrd/vmlinuz environment that was fixed on the netinst image.

Probably makes sense to close this out as I can no longer reproduce the issue (upgrade worked via netinst) unless someone else is having this problem or it rings a bell to one of the developers.

Comment 6 Chris Lumens 2010-04-28 01:37:53 UTC

*** This bug has been marked as a duplicate of bug 585621 ***


Note You need to log in before you can comment on or make changes to this bug.