Bug 585560 - [abrt] crash in terminator-0.14-4.fc12: config.py:493:__getitem__:GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://p
Summary: [abrt] crash in terminator-0.14-4.fc12: config.py:493:__getitem__:GError: Fai...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: terminator   
(Show other bugs)
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:876d7049
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-24 18:20 UTC by Ahmad Zulkarnain
Modified: 2010-05-13 19:33 UTC (History)
2 users (show)

Fixed In Version: terminator-0.93-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 12:24:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.69 KB, text/plain)
2010-04-24 18:20 UTC, Ahmad Zulkarnain
no flags Details

Description Ahmad Zulkarnain 2010-04-24 18:20:39 UTC
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/terminator
component: terminator
executable: /usr/bin/terminator
kernel: 2.6.32.11-99.fc12.i686.PAE
package: terminator-0.14-4.fc12
reason: config.py:493:__getitem__:GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Server ping error: IDL:omg.org/CORBA/UNKNOWN:1.0)
release: Fedora release 12 (Constantine)

backtrace
-----
config.py:493:__getitem__:GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Server ping error: IDL:omg.org/CORBA/UNKNOWN:1.0)

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/terminatorlib/terminatorterm.py", line 1004, in on_vte_key_press
    getattr(self, "key_" + mapping)()
  File "/usr/lib/python2.6/site-packages/terminatorlib/terminatorterm.py", line 1062, in key_split_horiz
    self.terminator.splitaxis (self, False)
  File "/usr/lib/python2.6/site-packages/terminatorlib/terminator.py", line 851, in splitaxis
    terminal = TerminatorTerm (self, self.profile, command, widget.get_cwd())
  File "/usr/lib/python2.6/site-packages/terminatorlib/terminatorterm.py", line 370, in __init__
    if not env_proxy and self.conf.http_proxy and self.conf.http_proxy != '':
  File "/usr/lib/python2.6/site-packages/terminatorlib/config.py", line 220, in __getattr__
    val = source[keyname]
  File "/usr/lib/python2.6/site-packages/terminatorlib/config.py", line 493, in __getitem__
    if self.client.get_bool ('/system/http_proxy/use_http_proxy'):
GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Server ping error: IDL:omg.org/CORBA/UNKNOWN:1.0)

Local variables in innermost frame:
key: 'http_proxy'
self: <terminatorlib.config.TerminatorConfValuestoreGConf object at 0xa2717cc>
ret: None
value: None

Comment 1 Ahmad Zulkarnain 2010-04-24 18:20:43 UTC
Created attachment 408866 [details]
File: backtrace

Comment 2 Fedora Update System 2010-04-24 18:58:30 UTC
terminator-0.93-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/terminator-0.93-1.fc13

Comment 3 Fedora Update System 2010-04-24 18:58:39 UTC
terminator-0.93-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/terminator-0.93-1.fc12

Comment 4 Dominic Hopf 2010-04-24 19:06:20 UTC
Thanks very much for reporting this issue. As soon as the new update for Terminator is available in updates-testing repository, the Fedora Update System will automatically will note it here.

Please note that the format of the configuration file changes with the update to Terminator 0.93, so you may would like to back up your ~/.config/terminator/ before updating. The issue most likely already is fixed in Terminator 0.93. Feel free to comment here if it still occurs. :)

Comment 5 Fedora Update System 2010-04-25 13:57:39 UTC
terminator-0.93-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update terminator'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/terminator-0.93-1.fc13

Comment 6 Fedora Update System 2010-04-27 02:16:11 UTC
terminator-0.93-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update terminator'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/terminator-0.93-1.fc12

Comment 7 Fedora Update System 2010-05-12 12:24:06 UTC
terminator-0.93-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-05-13 19:33:20 UTC
terminator-0.93-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.