Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585583 - SELinux is preventing /bin/bash "execute" access on /bin/hostname.
SELinux is preventing /bin/bash "execute" access on /bin/hostname.
Status: CLOSED DUPLICATE of bug 581303
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:d2f18edee27...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 17:49 EDT by marco
Modified: 2010-04-26 03:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 03:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marco 2010-04-24 17:49:06 EDT
Summary:

SELinux is preventing /bin/bash "execute" access on /bin/hostname.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by shorewall. It is not expected that this
access is required by shorewall and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:shorewall_t:s0
Target Context                system_u:object_r:hostname_exec_t:s0
Target Objects                /bin/hostname [ file ]
Source                        shorewall
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.0.35-3.fc12
Target RPM Packages           net-tools-1.60-99.fc12
Policy RPM                    selinux-policy-3.6.32-108.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.x86_64 #1
                              SMP Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sat 17 Apr 2010 11:27:36 PM CEST
Last Seen                     Sat 17 Apr 2010 11:27:36 PM CEST
Local ID                      919221e1-75f9-4e5b-9276-823186177b10
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1271539656.206:6): avc:  denied  { execute } for  pid=1379 comm="shorewall" name="hostname" dev=sdb2 ino=137476 scontext=system_u:system_r:shorewall_t:s0 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1271539656.206:6): arch=c000003e syscall=21 success=yes exit=0 a0=18b9460 a1=1 a2=7fffb602acd0 a3=e items=0 ppid=1369 pid=1379 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="shorewall" exe="/bin/bash" subj=system_u:system_r:shorewall_t:s0 key=(null)



Hash String generated from  catchall,shorewall,shorewall_t,hostname_exec_t,file,execute
audit2allow suggests:

#============= shorewall_t ==============
allow shorewall_t hostname_exec_t:file execute;
Comment 1 Miroslav Grepl 2010-04-26 03:39:15 EDT

*** This bug has been marked as a duplicate of bug 581303 ***

Note You need to log in before you can comment on or make changes to this bug.