Bug 585586 - SELinux is preventing /bin/bash "execute_no_trans" access on /usr/lib/vmware-tools/sbin32/vmware-guestd.
SELinux is preventing /bin/bash "execute_no_trans" access on /usr/lib/vmware-...
Status: CLOSED DUPLICATE of bug 581118
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:5ab4a496806...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 18:11 EDT by Rocco
Modified: 2010-04-26 05:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 05:21:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rocco 2010-04-24 18:11:50 EDT
Summary:

SELinux is preventing /bin/bash "execute_no_trans" access on
/usr/lib/vmware-tools/sbin32/vmware-guestd.

Detailed Description:

SELinux denied access requested by vmware-guestd. It is not expected that this
access is required by vmware-guestd and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:vmware_host_t:s0-s0:c0.c1023
Target Context                system_u:object_r:vmware_host_exec_t:s0
Target Objects                /usr/lib/vmware-tools/sbin32/vmware-guestd [ file
                              ]
Source                        ldd
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.0.33-1.fc12
Target RPM Packages           VMwareTools-8194-208167
Policy RPM                    selinux-policy-3.6.32-41.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.5-127.fc12.i686 #1
                              SMP Sat Nov 7 21:41:45 EST 2009 i686 i686
Alert Count                   2
First Seen                    Sat 24 Apr 2010 04:06:53 PM EDT
Last Seen                     Sat 24 Apr 2010 04:06:53 PM EDT
Local ID                      75dc2562-bad2-41d2-89ba-b0a60ce68e99
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1272139613.342:7): avc:  denied  { execute_no_trans } for  pid=1244 comm="vmware-guestd" path="/usr/lib/vmware-tools/sbin32/vmware-guestd" dev=dm-0 ino=87362 scontext=system_u:system_r:vmware_host_t:s0-s0:c0.c1023 tcontext=system_u:object_r:vmware_host_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1272139613.342:7): arch=40000003 syscall=11 success=no exit=-13 a0=8edefd0 a1=8edc740 a2=8ee08e0 a3=8edc740 items=0 ppid=1243 pid=1244 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="vmware-guestd" exe="/bin/bash" subj=system_u:system_r:vmware_host_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,ldd,vmware_host_t,vmware_host_exec_t,file,execute_no_trans
audit2allow suggests:

#============= vmware_host_t ==============
allow vmware_host_t vmware_host_exec_t:file execute_no_trans;
Comment 1 Miroslav Grepl 2010-04-26 05:21:41 EDT

*** This bug has been marked as a duplicate of bug 581118 ***

Note You need to log in before you can comment on or make changes to this bug.