Bug 585601 - printer autoconfig tries to install hpijs which is already installed
printer autoconfig tries to install hpijs which is already installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Triaged
: 604730 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 19:50 EDT by Tom Horsley
Modified: 2011-05-18 06:09 EDT (History)
9 users (show)

See Also:
Fixed In Version: PackageKit-0.6.14-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-09 00:09:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for review (11.20 KB, patch)
2011-03-30 10:21 EDT, Richard Hughes
no flags Details | Diff

  None (edit)
Description Tom Horsley 2010-04-24 19:50:36 EDT
Description of problem:

I just turned on my HP Photosmart C5580 All-In_one device for the first time
after installing fedora 13 Beta. It grinds for a while, then asks me if
I want to install hpijs. It thought hpijs was already installed, but to
humor it I said OK, then I got a Failed to install package error popup
with the details:

could not do simulate: The packages are already all installed

rpm -q does indeed show that I already have

hpijs-3.10.2-11.fc13.x86_64

on my system.

When I cancel the error popup, I get another popup about missing
printer driver.

If I then run s-c-p and try to add the printer manually, it detects
the printer and goes back to the asking to install hpijs dialog again.
This time I hit cancel up front and it searched for and found the already
installed driver.

After all that it seems to work OK :-).

Version-Release number of selected component (if applicable):
hpijs-3.10.2-11.fc13.x86_64
cups-1.4.3-6.fc13.x86_64
system-config-printer-1.2.1-1.fc13.x86_64


How reproducible:
I only tried it once, but that was enough :-).

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
Annoying trip to try and install already installed drivers.

Expected results:
Just install printer since driver is already there.

Additional info:
I have disabled many many insanely annoying startup apps in the gnome
session I am running. I don't know if it expects something to be there
that isn't there or what.
Comment 1 Tim Waugh 2010-04-25 05:17:17 EDT
I think this is because there is an hplip package in updates-testing.

Reassigning to PackageKit, which is returning packages it shouldn't:

[tim@localhost ~]$ rpm -q hpijs
hpijs-3.10.2-11.fc13.x86_64
[tim@localhost ~]$ pkcon --filter="~installed;arch;newest" what-provides "hp;psc_950;"
Getting provides              [=========================]         
Starting                      [=========================]         
Querying                      [=========================]         
Available   	hpijs-1:3.10.2-8.fc13.x86_64            	HP Printer Drivers
[tim@localhost ~]$ yum list hpijs
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Found 16 installed debuginfo package(s)
updates-testing/metalink                                 |  23 kB     00:00     
Enabling updates-testing-debuginfo: Fedora 13 - x86_64 - Test Updates Debug
Reading repository metadata in from local files
updates-testing-debuginfo/metalink                       |  18 kB     00:00     
Enabling fedora-debuginfo: Fedora 13 - x86_64 - Debug
Reading repository metadata in from local files
Installed Packages
hpijs.x86_64                  1:3.10.2-11.fc13                  @updates-testing
Comment 2 Richard Hughes 2010-04-25 17:59:40 EDT
(In reply to comment #1)
> [tim@localhost ~]$ rpm -q hpijs
> hpijs-3.10.2-11.fc13.x86_64
> [tim@localhost ~]$ pkcon --filter="~installed;arch;newest" what-provides
> "hp;psc_950;"
> Available    hpijs-1:3.10.2-8.fc13.x86_64             HP Printer Drivers

I think I see what is happening. We're doing the installed filtering before we're doing the newest filtering. This is really tricky to get right, because tecnically the newest package in the repote repos (that isn't the current installed package) is -8. I guess we shouldn't show packages less than the current installed version if the package is already installed.

I'll take a look at this early next week.

Richard.
Comment 3 Steven M. Parrish 2010-06-04 21:10:28 EDT
This bug has been triaged



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Tim Waugh 2010-07-16 08:28:02 EDT
*** Bug 604730 has been marked as a duplicate of this bug. ***
Comment 5 Joshua Rosen 2010-08-14 21:40:52 EDT
I'm seeing this with an HP F4400. It won't install the printer because hpjis is already installed. The work around was to remove hpjis with Yumex and then let the system-config-printer reinstall it.

BTW on a related topic, installing the printer requires four authorizations, this is idiotic, one authorization should be enough.
Comment 6 Tim Waugh 2010-08-16 06:17:30 EDT
(In reply to comment #5)
> BTW on a related topic, installing the printer requires four authorizations,
> this is idiotic, one authorization should be enough.

That's bug #596711.
Comment 7 Tim Waugh 2010-08-26 05:04:12 EDT
Would be great to get this fixed for F-14 if possible.
Comment 8 Tim Waugh 2010-11-18 11:13:49 EST
Still occurs in Fedora 14.
Comment 9 Jonathan Boulle 2011-03-14 15:41:13 EDT
Still occurring, very frustrating. I had foomatic-db-ppds-4.0-23.20101123.fc14.noarch installed and system-config-printer was trying to install an older version, and failing. Then I did a yum remove foomatic\*, and now s-c-p DOES want to install the latest version (the one I just removed!). And now it succeeds.
Comment 10 Tim Waugh 2011-03-29 06:46:13 EDT
This is still happening in F-15.  This makes it no easier, and certainly more confusing, than before we added any of the automatic driver bits. :-(
Comment 11 Richard Hughes 2011-03-30 10:21:34 EDT
Created attachment 488774 [details]
patch for review

This patch makes things work for me. Could somebody please test it for printer installing, and if it works I'll push into PackageKit git master for testing. Thanks.
Comment 12 Fedora Update System 2011-05-04 08:06:01 EDT
PackageKit-0.6.14-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/PackageKit-0.6.14-1.fc15
Comment 13 Fedora Update System 2011-05-05 00:43:16 EDT
Package PackageKit-0.6.14-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PackageKit-0.6.14-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/PackageKit-0.6.14-1.fc15
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2011-05-06 04:28:54 EDT
PackageKit-0.6.14-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/PackageKit-0.6.14-2.fc15
Comment 15 Fedora Update System 2011-05-09 00:09:04 EDT
PackageKit-0.6.14-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Tim Waugh 2011-05-18 06:09:09 EDT
Works here.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.