Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585602 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
[abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox wa...
Status: CLOSED DUPLICATE of bug 577621
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:51da9a9905fe40bc153533a166e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 19:57 EDT by orti1980
Modified: 2010-05-22 23:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-22 23:09:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (64.24 KB, text/plain)
2010-04-24 19:57 EDT, orti1980
no flags Details

  None (edit)
Description orti1980 2010-04-24 19:57:57 EDT
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5/firefox
component: firefox
executable: /usr/lib/firefox-3.5/firefox
kernel: 2.6.32.11-99.fc12.i686.PAE
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
Comment 1 orti1980 2010-04-24 19:57:59 EDT
Created attachment 408904 [details]
File: backtrace
Comment 2 Chris Campbell 2010-04-30 23:51:24 EDT
#3  <signal handler called>
No symbol table info available.
#4  operator= (this=0xbfc510c8, aRegion=...)
    at ../../dist/include/gfx/nsRegion.h:89
No locals.
#5  nsRegion::Copy (this=0xbfc510c8, aRegion=...) at nsRegion.cpp:591
        pSrc = 0x0
        pDest = 0xb022c1cc
#6  0x025df5a9 in nsViewManager::UpdateWidgetArea (this=0xb41da220, 
    aWidgetView=0xb41da280, aDamagedRegion=..., aIgnoreWidgetView=0x0)
    at nsViewManager.cpp:876
        damage = {mRectCount = 1, mCurRect = 0xb022c1cc, mRectListHead = 
    {<nsRegion::nsRectFast> = {<nsRect> = {x = 85504, y = 75776, width = 
    85760, height = 0}, <No data fields>}, prev = 0xb022c1cc, next = 
    0xb022c1cc}, mBoundRect = {<nsRect> = {x = 0, y = 0, width = 0, height = 
    0}, <No data fields>}}
        offset = {x = 1, y = -1077603876}
        view = 0xac8833a0
        childWidget = 0xaab85300
        intersection = {mRectCount = 1, mCurRect = 0xb765a61c, 
          mRectListHead = {<nsRegion::nsRectFast> = {<nsRect> = {x = 0, y = 
    0, width = 0, height = 0}, <No data fields>}, prev = 0xb765a61c, next = 
    0xb765a61c}, mBoundRect = {<nsRect> = {x = 420, y = 66780, width = 
    114240, height = 1020}, <No data fields>}}
        widget = 0xb42a1800
        children = {mRectCount = 0, mCurRect = 0xbfc51100, mRectListHead = 
    {<nsRegion::nsRectFast> = {<nsRect> = {x = 0, y = 0, width = 0, height = 
    0}, <No data fields>}, prev = 0xbfc51100, next = 0xbfc51100}, 
          mBoundRect = {<nsRect> = {x = 0, y = 0, width = 0, height = 
    0}, <No data fields>}}
        leftOver = {mRectCount = 44548813, mCurRect = 0x32730a4, 
          mRectListHead = {<nsRegion::nsRectFast> = {<nsRect> = {x = 
    -1077604096, y = -1376855184, width = -1077604040, height = 
    44548941}, <No data fields>}, prev = 0xaca9d000, next = 0xbfc510d0}, 
          mBoundRect = {<nsRect> = {x = 0, y = 0, width = 2105376125, 
              height = 1072528765}, <No data fields>}}
#7  0x025df84b in nsViewManager::UpdateView (this=0xb41da220, aView=
    0xb41da280, aRect=..., aUpdateFlags=0) at nsViewManager.cpp:926
        view = 0xb41da280
        damagedRect = {x = 420, y = 66780, width = 114240, height = 1020}
        rectVisibility = nsRectVisibility_kVisible
        displayRoot = 0xb41da280
#8  0x025e0797 in nsViewManager::DispatchEvent (this=0xb41da220, aEvent=
    0xbfc5139c, aStatus=0xbfc5130c) at nsViewManager.cpp:1189
        damRect = {x = 420, y = 66780, width = 114240, height = 1020}
        p2a = Cannot access memory at address 0x8



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Chris Campbell 2010-05-22 23:09:16 EDT
Thank you for taking the time to submit this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 577621 ***

Note You need to log in before you can comment on or make changes to this bug.