Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585625 - The list of languages in the spellcheck settings is in random order - very difficult to find the right language
The list of languages in the spellcheck settings is in random order - very di...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 02:19 EDT by Mattias Ellert
Modified: 2014-06-19 05:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: firefox-30.0-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-03 11:49:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The screenshot shows the list of languages in random order (140.77 KB, image/png)
2010-04-25 02:19 EDT, Mattias Ellert
no flags Details

  None (edit)
Description Mattias Ellert 2010-04-25 02:19:06 EDT
Created attachment 408924 [details]
The screenshot shows the list of languages in random order

Description of problem:
When selecting what languages to do spellcheck for the list is in random order. This makes it very difficult to find the right language

Version-Release number of selected component (if applicable):
firefox-3.6.3-4.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Expand the spellcheck language settings menu
  
Actual results:
The menu items are in random order

Expected results:
The menu items should be in alphabetical order
Comment 1 Mattias Ellert 2010-12-18 11:04:43 EST
Issue still exists in Fedora 14:
firefox-3.6.13-1.fc14.x86_64
Comment 2 Chris Campbell 2011-01-31 11:07:24 EST
Concise and everything looks good. Passing on as triaged.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Chris Campbell 2011-01-31 11:11:09 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Mattias Ellert 2012-07-12 18:48:43 EDT
Issue still present in F17 (firefox-13.0.1-1.fc17).
Comment 5 Martin Stransky 2012-08-06 10:13:19 EDT
Can you please retest with upstream binary?
Comment 6 Mattias Ellert 2012-08-08 07:26:17 EDT
The upstream binary I downloaded from mozilla.org appears to be a bit broken. It doesn't find the installed system dictionaries and only has an entry for "English (United States)" in the list. Since there in only one entry in the list I can not tell whether it is sorted or not. A list of one always appears to be sorted.
Comment 7 Mattias Ellert 2013-01-18 12:42:20 EST
Issue still present in F18 (firefox-18.0-1.fc18)
Comment 8 Thorsten Leemhuis 2013-03-02 02:21:11 EST
@Martin Stransky, how can we cat this longstanding and kind of small, but annoying bug resolved? I still see it in firefox-19.0-1.fc18.x86_64 and thunderbird-17.0.3-1.fc18.x86_64 

Do you want us to test upstream? Is that really relevant, as it seems it doesn't use the dictionaries installed in the system anyway and one has to manually install dicts first.

BTW, Bug 439598 might be a dupe of this (or the other way around)
Comment 9 Martin Stransky 2013-03-04 10:15:06 EST
Jan Horak is going to look at it.
Comment 10 Florian Weimer 2013-10-29 03:46:02 EDT
Also present in firefox-24.0-1.fc19.x86_64 and thunderbird-24.0-3.fc19.x86_64.
Comment 11 Jan Horak 2014-02-03 11:49:25 EST
There's an upstream bug for this: https://bugzilla.mozilla.org/show_bug.cgi?id=752474
We're going to track this issue it there.
Comment 12 Mattias Ellert 2014-06-19 05:50:11 EDT
Fianlly fixed...

Note You need to log in before you can comment on or make changes to this bug.