Bug 585689 - qemu-kvm: malloc.c:3096: sYSMALLOc: Assertion failed
qemu-kvm: malloc.c:3096: sYSMALLOc: Assertion failed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Beta/F13BetaBlocker
  Show dependency treegraph
 
Reported: 2010-04-25 12:09 EDT by Carl G.
Modified: 2013-01-09 06:33 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-31 14:36:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Crash info (3.48 KB, text/x-log)
2010-04-25 12:09 EDT, Carl G.
no flags Details

  None (edit)
Description Carl G. 2010-04-25 12:09:27 EDT
Created attachment 408973 [details]
Crash info

Description of problem:

After getting my computer back from S3 sleep, i got into my VM of Win7 to test the new OS from microsoft and the guest screen was ... weird. White w. multiple horizontal lines.

Version-Release number of selected component (if applicable):

qemu-kvm-0.12.3-8.fc13.x86_64
kernel 2.6.33.2-57.fc13.x86_64

How reproducible:

First time it happen. Idk.

Steps to Reproduce:
1. Start a VM
2. Put the computer into S3 sleep
3. Get back into the VM
4. ???
  
Actual results:

After a few seconds the VM crashed a few secs. after grabbing the mouse inside the VM.

Additional info:

Not sure if it belong to kvm.

----

Apr 25 11:45:22 BubbleWork abrtd: Directory 'ccpp-1272210307-19476' creation detected
Apr 25 11:45:23 BubbleWork kernel: virbr0: port 1(vnet0) entering disabled state
Apr 25 11:45:23 BubbleWork dnsmasq[1788]: reading /etc/resolv.conf
Apr 25 11:45:23 BubbleWork kernel: device vnet0 left promiscuous mode
Apr 25 11:45:23 BubbleWork kernel: virbr0: port 1(vnet0) entering disabled state
Apr 25 11:45:23 BubbleWork libvirtd: 11:45:23.077: error : qemuMonitorCommandWithHandler:254 : cannot send monitor command 'info balloon': Connection reset by peer
Apr 25 11:45:23 BubbleWork libvirtd: 11:45:23.098: error : qemuMonitorTextGetBalloonInfo:554 : operation failed: could not query memory balloon allocation
Comment 1 Carl G. 2010-04-25 12:42:17 EDT
Abrt failed to notice this bug :/


Core was generated by `/usr/bin/qemu-kvm -S -M fedora-13 -enable-kvm -m 768 -smp 1,sockets=1,cores=1,t'.
Program terminated with signal 6, Aborted.
#0  0x0000003138a33955 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
Missing separate debuginfos, use: debuginfo-install alsa-lib-1.0.23-1.fc13.x86_64 nss-softokn-freebl-3.12.4-17.fc13.x86_64
Comment 2 Carl G. 2010-04-25 14:50:13 EDT
Could it be a kernel bug, i also got the same error message w. Pino :

Core was generated by `pino'.
Program terminated with signal 6, Aborted.
#0  0x0000003138a33955 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);

See :
https://bugzilla.redhat.com/show_bug.cgi?id=585718
Comment 3 Carl G. 2010-04-30 21:13:35 EDT
Not sure what's going on here but i'm _still_ being able to reproduce this bug. I can provide any logs / info upon request if it's not already sufficient. 

It might also be a dupe, i'm not sure since ABRT failed to "catch" this bug.

Could someone try to reproduce it ?
Comment 4 Bug Zapper 2010-07-30 07:28:14 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Justin M. Forbes 2010-09-02 12:28:06 EDT
Is this still happening? I have not seen it with recent packages.
Comment 6 Carl G. 2010-10-31 14:36:17 EDT
(In reply to comment #5)
> Is this still happening? I have not seen it with recent packages.

Seems okay now ;)

Note You need to log in before you can comment on or make changes to this bug.