Bug 585696 - PackageKit or yumBackend.py stuck in infinite loop
PackageKit or yumBackend.py stuck in infinite loop
Status: CLOSED DUPLICATE of bug 577497
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 12:55 EDT by Carl-Johan Kjellander
Modified: 2014-01-21 18:14 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 14:27:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl-Johan Kjellander 2010-04-25 12:55:00 EDT
Description of problem:
For weeks yumBackend.py has been running against my
disks at an average if 85 MB/s. It or packagekitd
seems to be stuck in an infinite loop checking for
updates or something.

Version-Release number of selected component (if applicable):
# packagekit-bugreport.sh
Distro version:       Fedora release 12 (Constantine)
PackageKit version:   0.5.7
PackageKit Process Information:
root     10534  0.0  0.1 185104  4996 ?        Sl   17:50   0:03 /usr/sbin/packagekitd


How reproducible:
It is intermittent, but seems to loop over and over
every 40-50 seconds.

Steps to Reproduce:
1. Boot and login.
2. Wait and watch io with gkrellm.

  
Actual results:
It should check once per day, and a yum check shouldn't
take more than a minute.

Expected results:
It loops and loops for hours on end, and then says
188 updates or something similar and quits looping.

You update those, reboot, and then at some later point
it starts looping again.

There is nothing in the logs about yum or packagekit.


Additional info:
Comment 1 Carl-Johan Kjellander 2010-04-25 12:57:28 EDT
Oh, and it is persistent after reboots.
Comment 2 Richard Hughes 2010-04-26 08:29:36 EDT
Can you please do:

killall python
sudo /usr/share/PackageKit/helpers/yum/yumBackend.py get-updates none

And then print the output of the looping. Thanks.
Comment 3 Carl-Johan Kjellander 2010-04-26 08:44:26 EDT
# /usr/share/PackageKit/helpers/yum/yumBackend.py get-updates none
Error: No NETWORK envp
Error: No BACKGROUND envp
Loaded plugins: dellsysidplugin2, fastestmirror
No plugin match for: rpm-warm-cache
No plugin match for: remove-with-leaves
No plugin match for: auto-update-debuginfo
allow-cancel	false
allow-cancel	true
no-percentage-updates
status	info
Loading mirror speeds from cached hostfile
 * rpmfusion-free: fedora.uib.no
 * rpmfusion-free-updates: fedora.uib.no
 * rpmfusion-nonfree: fedora.uib.no
 * rpmfusion-nonfree-updates: fedora.uib.no
 * updates: redhat.linux.ee
status	download-updateinfo
subpercentage	0
subpercentage	99

----------- Here is stops until it has done one revolution of the loop
            this takes almost a minute. Then

subpercentage	100
status	download-updateinfo
subpercentage	0
subpercentage	99

----------- Another 1 minute churn

subpercentage	100
status	download-updateinfo
subpercentage	0
subpercentage	99

----------- Lather

subpercentage	100
status	download-updateinfo
subpercentage	0
subpercentage	99

----------- Rinse

subpercentage	100
status	download-updateinfo
subpercentage	0
subpercentage	99

----------- Repeat
Comment 4 Richard Hughes 2010-04-26 11:58:23 EDT
Reassigning to the yum guys for ideas. Feel free to re-assign back if you think it's something insane we're doing in PK.
Comment 5 seth vidal 2010-04-26 12:06:59 EDT
what ver of yum?

I expect it is the metadata reget bug.
Comment 6 Carl-Johan Kjellander 2010-04-26 14:01:57 EDT
yum-3.2.27-2.fc12.noarch
Comment 7 Carl-Johan Kjellander 2010-04-26 14:03:18 EDT
And this started happening some time during this spring. I've just haven't reported it. So it has been going on for a few weeks at least.
Comment 8 seth vidal 2010-04-26 14:09:23 EDT
grab yum-3.2.27-3.fc12, please. I think that will fix this.
Comment 9 Carl-Johan Kjellander 2010-04-26 14:25:26 EDT
I tested yum-3.2.27-3.fc12.noarch as per bug #577497 so it
is probably a dupe. But that bug shouldn't have been CLOSED
ERRATA before it was in stable for fc12.

output:
# /usr/share/PackageKit/helpers/yum/yumBackend.py get-updates none
Error: No NETWORK envp
Error: No BACKGROUND envp
Loaded plugins: dellsysidplugin2, fastestmirror
No plugin match for: rpm-warm-cache
No plugin match for: remove-with-leaves
No plugin match for: auto-update-debuginfo
allow-cancel true
status waiting-for-lock
message backend-error killing pid 7094, as old instance
allow-cancel false
allow-cancel true
no-percentage-updates
status info
Loading mirror speeds from cached hostfile
 * rpmfusion-free: fedora.uib.no
 * rpmfusion-free-updates: fedora.uib.no
 * rpmfusion-nonfree: fedora.uib.no
 * rpmfusion-nonfree-updates: fedora.uib.no
 * updates: redhat.linux.ee
status download-updateinfo
subpercentage 0
subpercentage 77
subpercentage 100
finished

Suggest marking this as dupe but reopening bug #577497.
Comment 10 seth vidal 2010-04-29 14:27:50 EDT
thanks - marking as a dupe and 3.2.27-3.fc12 is now pushed to stable.

sorry about the premature closing.

*** This bug has been marked as a duplicate of bug 577497 ***

Note You need to log in before you can comment on or make changes to this bug.