Bug 585697 - SELinux is preventing /usr/sbin/asterisk "write" access on /.asterisk_history.
SELinux is preventing /usr/sbin/asterisk "write" access on /.asterisk_hi...
Status: CLOSED DUPLICATE of bug 585695
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:ad510aecec1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 13:00 EDT by Kevin Gagnon
Modified: 2010-04-25 22:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-25 22:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Gagnon 2010-04-25 13:00:24 EDT
Summary:

SELinux is preventing /usr/sbin/asterisk "write" access on /.asterisk_history.

Detailed Description:

[asterisk has a permissive type (asterisk_t). This access was not denied.]

SELinux denied access requested by asterisk. It is not expected that this access
is required by asterisk and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:asterisk_t:s0-s0:c0.c1023
Target Context                system_u:object_r:etc_runtime_t:s0
Target Objects                /.asterisk_history [ file ]
Source                        asterisk
Source Path                   /usr/sbin/asterisk
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           asterisk-1.6.1.17-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-110.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.x86_64
                              #1 SMP Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Sun 18 Apr 2010 03:46:10 AM EDT
Last Seen                     Sun 25 Apr 2010 03:30:12 AM EDT
Local ID                      d28d0b41-1b31-4690-82d3-63f831a8de94
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1272180612.108:284): avc:  denied  { write } for  pid=15639 comm="asterisk" name=".asterisk_history" dev=dm-0 ino=12038 scontext=system_u:system_r:asterisk_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_runtime_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1272180612.108:284): arch=c000003e syscall=2 success=yes exit=6 a0=7fffb58ef410 a1=241 a2=1b6 a3=0 items=0 ppid=15638 pid=15639 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=40 comm="asterisk" exe="/usr/sbin/asterisk" subj=system_u:system_r:asterisk_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,asterisk,asterisk_t,etc_runtime_t,file,write
audit2allow suggests:

#============= asterisk_t ==============
allow asterisk_t etc_runtime_t:file write;
Comment 1 Carl G. 2010-04-25 22:27:56 EDT

*** This bug has been marked as a duplicate of bug 585695 ***

Note You need to log in before you can comment on or make changes to this bug.