Bug 585699 - [abrt] crash in xine-ui-0.99.6-0.1.20091217hg.fc12: Process /usr/bin/xine was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in xine-ui-0.99.6-0.1.20091217hg.fc12: Process /usr/bin/xine was...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xine-lib   
(Show other bugs)
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:53d90a80ae6331a3fa2dfb5b8c5...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-25 17:18 UTC by Igor Katalnikov
Modified: 2010-06-30 15:17 UTC (History)
2 users (show)

Fixed In Version: xine-lib-1.1.18.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 15:17:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (33.48 KB, text/plain)
2010-04-25 17:18 UTC, Igor Katalnikov
no flags Details

Description Igor Katalnikov 2010-04-25 17:18:07 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: xine /home/igor/Download/The_Colour_of_Magic_2008.mkv
component: xine-ui
executable: /usr/bin/xine
global_uuid: 53d90a80ae6331a3fa2dfb5b8c5ac15a2aa72e0d
kernel: 2.6.32.11-99.fc12.i686.PAE
package: xine-ui-0.99.6-0.1.20091217hg.fc12
rating: 4
reason: Process /usr/bin/xine was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.Tryed to play H264 mkv video file
2.
3.

Comment 1 Igor Katalnikov 2010-04-25 17:18:09 UTC
Created attachment 408981 [details]
File: backtrace

Comment 2 Thomas Janssen 2010-05-02 14:36:54 UTC
It's not the mkv container itself. xine-ui plays just fine http://matroska.free.fr/samples/matrix/Matrix.Reloaded.Trailer-640x346-XviD-1.0beta2-HE_AAC_subtitled.mkv 
for example.

I would suggest to file the bug upstream. I have no H264 mkv video file to reproduce, and the one you tried is only available via some torrent pages.

I will file the bug upstream for you.

Comment 3 Igor Katalnikov 2010-05-04 06:01:20 UTC
Thanx. Seem to be a known bug. 

http://forums.gentoo.org/viewtopic-t-801090-start-0-postdays-0-postorder-asc-highlight-.html

reports that it is solved in xine-lib 1.1.17. Should be nice to have it ported to FC12.

Comment 4 Thomas Janssen 2010-05-04 21:01:22 UTC
Changing Assigned to xine-lib

http://bugs.xine-project.org/show_bug.cgi?id=270

There's the patch to fix it.

Thanks Igor!

Comment 5 Igor Katalnikov 2010-05-04 21:31:28 UTC
I suggest to close this bug. xine-lib 1.1.18 is available in FC13. Rather crude solution:

1. Install ATrpms from http://atrpms.net/dist/f12/atrpms-repo/
2. Hit yum update

(this updates a lot of ffmpeg like stuff including xine-lib if already installed)

solved a lot of video playback hick-ups for me. Including this one.

The proper solution would be backport FC13 version of xine-lib to FC12 though.

Comment 6 Kevin Kofler 2010-05-04 22:37:59 UTC
We should push 1.1.18 as an update. Please don't close this bug until resolved in F12.

Comment 7 Rex Dieter 2010-05-04 23:52:05 UTC
yeah, an update is definitely doable, was waiting for f13 testing and things to cool down a bit before doing so though.

Comment 8 Fedora Update System 2010-06-21 15:44:39 UTC
xine-lib-1.1.18.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xine-lib-1.1.18.1-1.fc12

Comment 9 Fedora Update System 2010-06-22 17:19:39 UTC
xine-lib-1.1.18.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-lib'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/xine-lib-1.1.18.1-1.fc12

Comment 10 Fedora Update System 2010-06-30 15:17:05 UTC
xine-lib-1.1.18.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.