Bug 585706 - SCIM makes typing with keyboard in Firefox and Thunderbird extremely slow
SCIM makes typing with keyboard in Firefox and Thunderbird extremely slow
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 14:00 EDT by zimon
Modified: 2010-04-27 21:13 EDT (History)
4 users (show)

See Also:
Fixed In Version: scim-bridge-0.4.16-5.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 21:13:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zimon 2010-04-25 14:00:06 EDT
Description of problem:

I have had this problem a long time. I at first thought this problem came with Firefox 3.x, or with Fedora 9 -> 11/12. I do not remember I had this problem in Fedora 9, so after that anyhow.

When Firefox has been in use actively for several hours, typing into input fields with keyboard becomes untolerable slow (2 letters per second or slower).
Restarting Firefox fixes the problem for some time until after some hours use it manifests again.


I have used often a way, where I first type the text of my forum message in terminal window, then copy it to the clipboard and paste it to Firefox so I wouldn't have to restart the browser. PASTEing from the clipboard is as fast as always even if typing has become slow in Firefox.

Later I started to use Thunderbird's "New Email"-form for this same purpose, because it has thesaurus. Then I noticed also Thunderbird is having this same bug, so I started to search problem elsewhere than from Firefox plugins.

I haven't noticed the same in other application but Firefox and Thunderbird.
I've spent I think several working days in total trying to find the problem by uninstalling all the extensions, plugins, starting fresh profiles, Googling around and in other ways trying to debug the problem.

Version-Release number of selected component (if applicable):

The latest SCIM-packages which were available from Fedora 12 repositories in 2010-04-23

scim v 1.4.9
scim-bridge v 0.4.16
(and other related scim-components)

How reproducible:
Always

Steps to Reproduce:
1. Using Firefox or Thunderbird long(ish) time.
2. Typing something to any input field (chat forums, new email,....)
3. Typing is VERY slow, like one - two letters per second. However PASTEing from clipboard is as fast.
  


Expected results:
To have usable Firefox where typing in input fields is not a torture.

Additional info:

I started Thunderbird under gdb to see what it is doing when typing becomes slow. ($ thunderbird -g)

TB became slow in typing. I typed many key presses to the buffer and interrupted thunderbird from gdb (^C):
: bt
#0  0x0000003b690d73c3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fffe4d68d62 in scim_bridge_messenger_receive_message (messenger=
    0x7fffdf5c98d0, timeout=0x0) at scim-bridge-messenger.c:490
#2  0x00007fffe4d6bdb9 in scim_bridge_client_read_and_dispatch ()
     at scim-bridge-client.c:1216
#3  0x00007fffe4d6d215 in scim_bridge_client_handle_key_event (
     imcontext=<value optimized out>, key_event=0x7fffd0775920, consumed=
     0x7fffffffd3e4) at scim-bridge-client.c:1738
#4  0x00007fffe4d66b2f in filter_key_event (imcontext=
     0x7fffd3041080 [ScimBridgeClientIMContext], event=0x7fffcfa8ab30, consumed=
     0x7fffffffd3e4) at scim-bridge-client-imcontext-gtk.c:159
#5  0x00007fffe4d66c02 in key_snooper (widget=<value optimized out>, event=
     0x7fffcfa8ab30, data=<value optimized out>)
     at scim-bridge-client-imcontext-gtk.c:220
#6  0x0000003b7214bb7d in gtk_invoke_key_snoopers (event=0x7fffcfa8ab30)
     at gtkmain.c:1929
#7  IA__gtk_main_do_event (event=0x7fffcfa8ab30) at gtkmain.c:1614
#8  0x0000003b7105feac in gdk_event_dispatch (source=<value optimized out>,
     callback=<value optimized out>, user_data=<value optimized out>)
     at gdkevents-x11.c:2372
#9  0x0000003b6a83923e in g_main_dispatch (context=0x7ffff7d176d0)
     at gmain.c:1960
#10 IA__g_main_context_dispatch (context=0x7ffff7d176d0) at gmain.c:2513

So, I was wondering, I really do not need SCIM for anything, so I try to remove it. I removed all scim-pacakges. From /var/log/yum.log:
Apr 23 23:40:03 Erased: scim-bridge-gtk
Apr 23 23:40:04 Erased: scim-bridge-qt
Apr 23 23:40:05 Erased: scim-qtimm
Apr 23 23:40:06 Erased: scim-chewing
Apr 23 23:40:07 Erased: scim-python-pinyin
Apr 23 23:40:10 Erased: scim
Apr 23 23:40:14 Erased: scim-python
Apr 23 23:40:16 Erased: scim-bridge
Apr 23 23:40:17 Erased: scim-hangul
Apr 23 23:40:18 Erased: scim-rawcode
Apr 23 23:40:19 Erased: scim-anthy
Apr 23 23:40:20 Erased: scim-m17n
Apr 23 23:45:26 Erased: scim-libs
And rebooted the system.

After this I haven't (seem to) had the problem anymore. I can now use Firefox without needing to restart it after few hours because slow typing. Haven't yet used Thunderbird so much that I could confirm the problem is vanished from that also, but the problem was so much the same, I suspect removing SCIM helped there also.
Comment 1 Peng Wu 2010-04-26 03:53:43 EDT
In the past we received a very similar bug report, see below:
Bug 554025 - Text input in firefox becomes increasingly sluggish; an excessive number of scim messages are observed.

I will push this to Fedora 12 updates soon. Please test the package provided below.
Comment 2 Fedora Update System 2010-04-26 04:03:41 EDT
scim-bridge-0.4.16-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/scim-bridge-0.4.16-5.fc12
Comment 3 Fedora Update System 2010-04-26 22:18:20 EDT
scim-bridge-0.4.16-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scim-bridge'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/scim-bridge-0.4.16-5.fc12
Comment 4 Fedora Update System 2010-04-27 21:13:28 EDT
scim-bridge-0.4.16-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.