Bug 58576 - rpmmodule.c is unusable
Summary: rpmmodule.c is unusable
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-python (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 58583 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-20 12:13 UTC by Michael Lipp
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 21:18:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Lipp 2002-01-20 12:13:12 UTC
The rpmmodule.c has (since several versions of rpm) a wrongly defined method
table. E.g.

	{"verifyFile",	(PyCFunction) hdrVerifyFile,	1 },

does not work, becaus "1" means METH_VARARGS and in thos case the argument is
a python tuple. The associated function expects an interger, however:

  static PyObject * hdrVerifyFile(hdrObject * s, PyObject * args) {

    if (!PyInt_Check(args)) {
	PyErr_SetString(PyExc_TypeError, "integer expected");
	return NULL;
    }

This applies to several functions in rpmmodule.c. making these functions
effectivly unusable.

Comment 1 Jeff Johnson 2002-08-07 23:19:51 UTC
hdrVerifyFile is now removed from the
bindings. Will be resurrrected as a
binding to rpmcliVerify somwhen.

Change will be in rpm-4.1-0.76 when built.

Comment 2 Jeff Johnson 2002-08-07 23:20:50 UTC
*** Bug 58583 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.