Bug 58577 - Dialup local IP address = LAN hostname address
Summary: Dialup local IP address = LAN hostname address
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-20 13:25 UTC by Jim Hobbs
Modified: 2007-04-18 16:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 15:58:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Provide option to retrieve local ip from remote host (4.51 KB, patch)
2002-01-26 23:42 UTC, Michael Chapman
no flags Details | Diff
Use "noipdefault" pppd option when retrieving local IP from remote host (511 bytes, patch)
2002-01-26 23:44 UTC, Michael Chapman
no flags Details | Diff

Description Jim Hobbs 2002-01-20 13:25:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i586)

Description of problem:
When using the normal (menu "dialup configuration") setups for dialing an ISP,
pppd often negotiates the hostname's LAN address (192.168.0.x) for the local IP
address.  This results in several dialup attempts required before successful
connection.  

Note:  Adding "noipdefault" to /etc/ppp/options seems to have fixed this. 
Perhaps this should be done automatically when using dynamic address assignment?

Also note:  Happens only after setting up a LAN.  Didn't happen before this,
when the host address was only 127.0.0.1.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Configure system for use in a LAN, using an ethernet connection.
2. Set up a dialup network connection.
3. Attempt to make the dialup connection several times.

Actual Results:  pppd often successfully negotiates my hostname's LAN address as
the local IP address for the ppp connection, resulting in no communication.

Expected Results:  pppd should have allowed the ISP to dynamically assign the
local IP address.

Additional info:

Comment 1 Michael Chapman 2002-01-26 23:40:33 UTC
I am having this problem too. After connecting, /sbin/ifconfig shows my ppp
connection's local ip address as 192.168.0.2, which is my eth0's address on my
home lan.

Perhaps rp3 should have an option to get the connection's local IP from the
remote host? I've constructed two patches that address this problem (one for
rp3, one for initscripts). Since they seem to work well I'll attach them to this
bug.


Comment 2 Michael Chapman 2002-01-26 23:42:47 UTC
Created attachment 43635 [details]
Provide option to retrieve local ip from remote host

Comment 3 Michael Chapman 2002-01-26 23:44:51 UTC
Created attachment 43636 [details]
Use "noipdefault" pppd option when retrieving local IP from remote host

Comment 4 Thomas Woerner 2004-08-16 15:58:39 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.




Note You need to log in before you can comment on or make changes to this bug.