Bug 58581 - package of xine 0.9.8-1 without X11 drivers
Summary: package of xine 0.9.8-1 without X11 drivers
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xine (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-20 17:38 UTC by Miguel Freitas
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-22 11:37:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miguel Freitas 2002-01-20 17:38:34 UTC
Description of problem:
The package on rawhide of xine 0.9.8 misses the X11 video drivers.
These are the main display drivers (xineplug_vo_out_xshm and 
xineplug_vo_out_xv).

Version-Release number of selected component (if applicable):
0.9.8-1

How reproducible:
Always

There must be some problem with your building system.
Check configure results to see why it doesn't build X11 drivers.

Comment 1 Bernhard Rosenkraenzer 2002-01-22 11:37:25 UTC
This seems to be a very weird automake issue - they're being built, but they're
being built as static libraries rather than shared ones, therefore make install
can't find them (and if it did xine wouldn't be able to use them).


Comment 2 Bernhard Rosenkraenzer 2002-01-22 11:53:06 UTC
Workaround found and added in 0.9.8-3.

Comment 3 Bernhard Rosenkraenzer 2002-01-22 11:55:22 UTC
FYI: The problem is that libtool messes up on the plugins.

-lXinerama and -lXv are used, both of which are available as static libraries only.
Now libtool is "intelligent" and thinks anything that links to a static library
must be static itself.

Replacing -lXinerama with /usr/X11R6/lib/libXinerama.a and -lXv with
/usr/X11R6/lib/libXv.a fixes this (libtool doesn't detect this as an attempt to
link to a static library).

Comment 4 Stefan Sorensen 2002-01-24 17:14:02 UTC
This does not fix the problem, libtool simply drops the archives (another
libtool bug?), resulting in unresolved references when loading the plugin.

The right fix is to use the libtool from rawhide where the bug (#54887) is fixed
(just erase ltmain.sh before the autoreconf step).


Comment 5 Bernhard Rosenkraenzer 2002-01-24 17:28:38 UTC
You must both use the libtool from rawhide and use the hack I mentioned above. ;)

The libtool from rawhide without the hack will not provide the plugins
at all because it'll generate static libraries instead.


Note You need to log in before you can comment on or make changes to this bug.