Bug 58582 - quotaon doesn't recognize v2 Quota
quotaon doesn't recognize v2 Quota
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-20 14:19 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-07 06:43:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-20 14:19:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [de] (X11; U; Linux 2.4.17 i686)

Description of problem:
quotaon doesn't recognize Version2 quota which quotacheck -F vsfv0 /dev/hda?
produces.
If you want to enable quotas, quotaon tells you it couldn't find quota.user and
doesn't look for aquota.user, so it doesn't start the quotasystem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add usrquota in /etc/fstab to selected partition
2. quotacheck -F vsfv0 /dev/hda? (produces aquota.user)
3. edquota $user 
4. quotaon /dev/hda?	

Actual Results:  quotaon can't find quota.user (of course, the file doesn't
exist), but doesn't look for aquota.user (exists) and there is no -F vfsv0
switch like for quotacheck or edquota.

Expected Results:  quotaon should start Version2 quotasystem.

Additional info:

If I use -F vfsold for quotacheck and edquota, it produces quota.user and
quotaon is able to start the quotas.
But I would like to use v2 quotas.
Kernel is a handmade 2.4.17 with enables quota-support
Comment 1 Steve Tate 2002-05-01 00:01:41 EDT
I had this problem too, so checked here and noticed this bug report.

Then I tracked down what the problem is -- the problem is that the RedHat
kernels use the Alan Cox (ac) patches, which change the way quotas work in the
kernel in a fundamental way (changes the command codes to the quotactl system
call among other things).  Since the quotaon binary is compiled against the
ac-patched kernel and you (and I) are running the standard Linux kernel, the
commands don't match up and the quotactl call doesn't work right.

I haven't tried this yet, but I am going to try to recompile the quota
package binaries against the standard 2.4.17 kernel to see if that works.

[ Personal rant:  I think Red Hat using such a drastically different kernel (a
7.8 Meg patch to the kernel source) is a really bad idea.  Sure
Alan Cox knows what he's doing, but this is the kind of kernel forking is
really a bad thing -- there's nothing wrong with the standard kernel! ]
Comment 2 Steve Tate 2002-05-01 11:32:41 EDT
OK, I tried what I mentioned above, and it seems the quota user-level packages
are pretty closely tied to the ac kernel patches, so just recompiling with
the standard 2.4.17 definitions did not work.

I do have it working now, but not with the 2.4.17 kernel.  I patched up to the
2.4.18 kernel, then applied the ac patches to make a 2.4.18-ac3 kernel, and then
everything works great.  I'm still somewhat annoyed that the quota package
doesn't work with a standard kernel, but since it's working now I'm finding it
harder to be *seriously* annoyed....

Comment 3 Peter Surda 2002-05-07 06:43:21 EDT
It seems that in some secret hidden place on a filesystem, it is written whether
new or old quotas should be used for "quotaon". Try removing aquota.user, then
run convertquota, quotacheck and quotaon. Now it should work. Unfortunately it
wipes the quota data, so if you want to keep it, you have to find a way to do a
backup/restore.
Comment 4 Phil Copeland 2002-08-07 12:13:28 EDT
There is a new errata candidate for the 7.x series, quota-3.06) kicking around
in rawhide (ftp://ftp.redhat.com:/pub/redhat/linux/rawhide/SRPMS/SRPMS) that
should address this issue with v1/v2 quota file formats.

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.