Bug 585918 - DeviceError: ('device has not been created', 'sda3')
DeviceError: ('device has not been created', 'sda3')
Status: CLOSED DUPLICATE of bug 583290
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 08:29 EDT by Daniel Qarras
Modified: 2010-05-10 08:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 08:17:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda crash dump (316.59 KB, text/plain)
2010-04-26 08:29 EDT, Daniel Qarras
no flags Details

  None (edit)
Description Daniel Qarras 2010-04-26 08:29:09 EDT
Created attachment 409165 [details]
anaconda crash dump

Description of problem:
When installing Fedora 13 Beta Anaconda crashed during partitioning and generated the attached crash dump. I'm not able to check from the dump whether this issue has been reported already before or not.
Comment 1 Daniel Qarras 2010-04-26 08:29:51 EDT
It should be mentioned that after the crash I manually created the partitions and the next installation finished normally.
Comment 2 Chris Lumens 2010-04-27 10:52:45 EDT
anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 607, in setup
    raise DeviceError("device has not been created", self.name)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 264, in execute
    self.device.setup()
  File "/usr/lib/anaconda/storage/devicetree.py", line 672, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 290, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceError: ('device has not been created', 'sda3')
Comment 3 Chris Lumens 2010-04-30 15:45:15 EDT
Can you explain what you were trying to do during partitioning?  Is RAID involved at all?
Comment 4 Daniel Qarras 2010-05-03 14:59:11 EDT
> Can you explain what you were trying to do during partitioning?  Is RAID
> involved at all?

No RAID or even LVM involved at all. I have a laptop with two Windows related partitions and before installation attempt I had /boot, swap and / and I was from the installer GUI deleting those three partitions and trying to create two new primary partitions, swap and /.

After the installer crashed I created those partitions by hand with fdisk and on the next attempt the installer managed to format them. fdisk -l now gives:

root@localhost:~# fdisk -l

Disk /dev/sda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa1dfa2ed

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         383     3076416   12  Compaq diagnostics
/dev/sda2             384       10870    84236827+   7  HPFS/NTFS
/dev/sda3           10871       11003     1068322+  82  Linux swap / Solaris
/dev/sda4   *       11004       12161     9301635   83  Linux

When I used fdisk few megabytes were shown as unallocated/free space by the installer during the second attempt but when the installer was trying to do partitioning all the space was used (so fdisk and anaconda create slightly different kind of partition layout).

Thanks.
Comment 5 Hans de Goede 2010-05-10 08:17:54 EDT
Looking at the log, this is caused by to aggressive pruning of device actions, which is fixed by this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=f420bf4f8d90af943be970dca37e72b6a1682c89

*** This bug has been marked as a duplicate of bug 583290 ***

Note You need to log in before you can comment on or make changes to this bug.