Bug 585947 - redhat-lsb provides support for lsb-4.0, but inadequate dependencies to provide 4.0 support
redhat-lsb provides support for lsb-4.0, but inadequate dependencies to provi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-lsb (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Lawrence Lim
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 10:13 EDT by Stew Benedict
Modified: 2014-03-25 21:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:48:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
redhat-lsb (5.02 KB, text/plain)
2011-01-27 02:22 EST, Ying Cui
no flags Details

  None (edit)
Description Stew Benedict 2010-04-26 10:13:02 EDT
Description of problem:
The redhat-lsb package in the RHEL6 beta reports lsb-4.0 support via the lsb_release command, but in setting up tests I found I had to manually find and retrieve many packages via yum. Looking at the --requires of the package it looks more like the 3.0 set of dependencies, with no printing or desktop support. Yum does not seem to be able to find the foomatic-rip command at all, which is a required part of LSB >= 3.2.

Version-Release number of selected component (if applicable):
redhat-lsb-4.0-2.1.el6.i686

How reproducible:
very

Steps to Reproduce:
1. install redhat-lsb
2. type lsb_release -a - note 4.0 support
3. type rpm -q --requires redhat-lsb and note the list in comparison to the actual requirements of LSB = 3.2
  
Actual results:
while step 2 indicates 4.0 support, step 3 and subsequent distribution testing reveal many missing components

Expected results:
redhat-lsb should require the printing subsystem, and well as the desktop components (libcups, foomatic-rip, /usr/share/ppd, qt3/4, gtk, xml, xft, freetype, ...)

Additional info:
For what it's worth, there is a patch here that was provided for RHEL5 that should update the dependencies.

http://dev.linuxfoundation.org/~stewb/RHEL53/redhat-lsb.spec.diff
Comment 2 RHEL Product and Program Management 2010-04-26 11:15:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Bill Nottingham 2010-04-26 13:48:52 EDT
Printing and desktop are separate subpackages, which (due to an error) are in the 'Optional' repository at the moment.
Comment 4 Stew Benedict 2010-04-30 07:55:44 EDT
Thanks Bill. I have enabled the 'Optional' repository and was able to install -printing and -desktop. A couple of issues:

redhat-lsb should require the subpackages. At this point there is no seperation of requirements for a server or desktop LSB implementation.

Neither of these packages have any requirements of their own, and installing them with yum did not add the missing pieces needed for LSB >= 3.2.
Comment 5 Bill Nottingham 2010-04-30 14:05:02 EDT
(In reply to comment #4)
> redhat-lsb should require the subpackages. At this point there is no seperation
> of requirements for a server or desktop LSB implementation.

That defeats the point of splitting it if installing the LSB support pulls everything in.

> Neither of these packages have any requirements of their own, and installing
> them with yum did not add the missing pieces needed for LSB >= 3.2.    

That just sounds like a bug.
Comment 6 RHEL Product and Program Management 2010-07-15 10:33:18 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 7 Stew Benedict 2010-09-02 07:49:47 EDT
As of REHL6-beta2, this situation is still pretty much the same. I'm not finding anything that requires the language modules (perl, python), and in fact by updating to Beta2, perl-CGI seems to have just "gone away" (required by LSB 4.0+). As a result, there are 14 failures in the perl tests.
Comment 8 Bill Nottingham 2010-09-02 15:37:00 EDT
perl::CGI is provided by the main perl package, AFAIK.
Comment 9 Stew Benedict 2010-09-03 08:43:03 EDT
Yes, it is part of the upstream perl tarball, which is why it's included as a required component for LSB.

But...distributions have gotten creative in packaging perl and split it up in various ways. I don't find a reference in the changelog to actually removing it, but I'm not finding perl::CGI or perl, perl-core or any repos that my yum (possibly limited) has access to in the RHEL6-beta2. I know some distributions package it seperately or substitute in the CPAN version, but in this case I just can't find it at all.


[stew@rhel6-32 ~]$ rpm -q perl
perl-5.10.1-113.el6.i686
[stew@rhel6-32 ~]$ rpm -V perl
[stew@rhel6-32 ~]$ rpm -q perl-core
perl-core-5.10.1-113.el6.i686
[stew@rhel6-32 ~]$ rpm -V perl-core

Running one of the failing tests:
[root@rhel6-32 perl]# ./single_test ../lib/CGI/t/apache.t
../lib/CGI/t/apache....1..1
not ok 1 - use CGI::Apache;

#   Failed test 'use CGI::Apache;'
#   at ../lib/CGI/t/apache.t line 13.
#     Tried to use 'CGI::Apache'.
#     Error:  Can't locate CGI/Apache.pm in @INC (@INC contains: blib/lib blib/arch t/lib /opt/lsb/test/perl/5.10.0/tlib /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl/ /usr/share/perl5/vendor_perl/ /usr/lib/perl5/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl . './' /opt/lsb/test/perl/lib) at (eval 4) line 2.
# BEGIN failed--compilation aborted at (eval 4) line 2.
# Looks like you failed 1 test of 1.
dubious
	Test returned status 1 (wstat 256, 0x100)
DIED. FAILED test 1
	Failed 1/1 tests, 0.00% okay
Failed Test           Stat Wstat Total Fail  List of Failed
-------------------------------------------------------------------------------
../lib/CGI/t/apache.t    1   256     1    1  1
Failed 1/1 test scripts. 1/1 subtests failed.
Files=1, Tests=1,  1 wallclock secs ( 0.09 cusr +  0.26 csys =  0.35 CPU)
Failed 1/1 test programs. 1/1 subtests failed.


[root@rhel6-32 ~]# yum search CGI | grep perl
perl-CGI-Session.noarch : Persistent session data in CGI applications
mod_perl.i686 : An embedded Perl interpreter for the Apache HTTP Server
perl.i686 : Practical Extraction and Report Language
perl-Frontier-RPC.noarch : A Perl interface for making and serving XML-RPC calls
perl-Image-Size.noarch : Determine the size of images in several common formats
Comment 10 Bill Nottingham 2010-09-03 11:11:05 EDT
I'm looking at a more current tree, and I see perl-CGI, still as a separate package. (It's part of the main perl package in later Fedora releases.)

Looks like this was fixed post-beta2.
Comment 18 errata-xmlrpc 2011-05-19 09:48:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0639.html

Note You need to log in before you can comment on or make changes to this bug.