Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 585951 - A process using kvm can enter a non-killable state
A process using kvm can enter a non-killable state
Status: CLOSED DUPLICATE of bug 588251
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 10:19 EDT by Naphtali Sprei
Modified: 2010-05-04 03:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 03:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test-case for the bug (68.90 KB, application/octet-stream)
2010-04-26 10:22 EDT, Naphtali Sprei
no flags Details

  None (edit)
Description Naphtali Sprei 2010-04-26 10:19:45 EDT
Description of problem:

While running one of the qemu-kvm unit test (called access), the qemu process
gets to a state that it cannot be killed. When killed, the process get's zombied
but continue to consume resources.

Version-Release number of selected component (if applicable):
kvm-83-143.el5

How reproducible:
Consistently, every time.

Steps to Reproduce:
1. qemu-kvm -kernel access.flat (the attached test-case)

   This test-case was/can be built from qemu-kvm unit tests.
   clone an upstream qemu-kvm git repo, go to its subdir kvm/user and type make
   test-cases are created in test/x86 subdir, including access.flat
   Intended test runs with following parameters to produce output:
    "-kernel access.flat -device testdev,chardev=testlog -chardev file,id=testlog,path=access.log", where access.log is an example of an output file
2. wait about 5 minutes

   Actually, the test-case runs lots of sub-test-cases until it reaches the problematic sub-test-case that causes this problem. You can follow the output to see when it's stuck.

3. try to kill qemu-kvm process
  
Actual results:
qemu-kvm process keeps running

Expected results:
qemu-kvm process killed and disappear

Additional info:
Comment 1 Naphtali Sprei 2010-04-26 10:22:19 EDT
Created attachment 409187 [details]
test-case for the bug
Comment 2 Marcelo Tosatti 2010-05-04 03:38:59 EDT

*** This bug has been marked as a duplicate of bug 588251 ***

Note You need to log in before you can comment on or make changes to this bug.