Bug 585966 - SELinux is preventing /opt/google/chrome/chrome-sandbox "write" access on oom_adj.
SELinux is preventing /opt/google/chrome/chrome-sandbox "write" access on oom...
Status: CLOSED DUPLICATE of bug 581256
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:c688828154c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 10:34 EDT by Matt Matti
Modified: 2010-05-20 15:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 11:28:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Matti 2010-04-26 10:34:14 EDT
Summary:

SELinux is preventing /opt/google/chrome/chrome-sandbox "write" access on
oom_adj.

Detailed Description:

[chrome-sandbox has a permissive type (chrome_sandbox_t). This access was not
denied.]

SELinux denied access requested by chrome-sandbox. It is not expected that this
access is required by chrome-sandbox and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:unconfined_r:unconfined_execmem_t:s0-
                              s0:c0.c1023
Target Objects                oom_adj [ file ]
Source                        chrome-sandbox
Source Path                   /opt/google/chrome/chrome-sandbox
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           google-chrome-beta-5.0.342.9-43360
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-41.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.5-127.fc12.i686 #1 SMP Sat
                              Nov 7 21:41:45 EST 2009 i686 i686
Alert Count                   1
First Seen                    Mon 26 Apr 2010 10:28:44 AM EDT
Last Seen                     Mon 26 Apr 2010 10:28:44 AM EDT
Local ID                      9a487174-a6c8-4f71-b4af-a655040b522b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1272292124.201:25644): avc:  denied  { write } for  pid=7803 comm="chrome-sandbox" name="oom_adj" dev=proc ino=346107 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_execmem_t:s0-s0:c0.c1023 tclass=file

node=(removed) type=SYSCALL msg=audit(1272292124.201:25644): arch=40000003 syscall=5 success=yes exit=3 a0=bf8a8ea5 a1=8001 a2=0 a3=1e78 items=0 ppid=2099 pid=7803 auid=500 uid=500 gid=500 euid=0 suid=0 fsuid=0 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="chrome-sandbox" exe="/opt/google/chrome/chrome-sandbox" subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-41.fc12,catchall,chrome-sandbox,chrome_sandbox_t,unconfined_execmem_t,file,write
audit2allow suggests:

#============= chrome_sandbox_t ==============
allow chrome_sandbox_t unconfined_execmem_t:file write;
Comment 1 Matt Matti 2010-04-26 10:35:59 EDT
just browsing the web while doing a software update
Comment 2 Daniel Walsh 2010-04-26 11:28:42 EDT

*** This bug has been marked as a duplicate of bug 581256 ***

Note You need to log in before you can comment on or make changes to this bug.