Bug 585990 - Please upgrade to git-1.7.x
Please upgrade to git-1.7.x
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: git (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Tkac
qe-baseos-daemons
: Rebase
Depends On:
Blocks: 600411
  Show dependency treegraph
 
Reported: 2010-04-26 11:32 EDT by Todd Zullinger
Modified: 2013-04-30 19:46 EDT (History)
8 users (show)

See Also:
Fixed In Version: git-1.7.1-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:28:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Zullinger 2010-04-26 11:32:49 EDT
In RHEL6 beta, git-1.6.5.2 is included.  Previously, git was provided for EL-5 via EPEL.  We'd like to rebase the EL-5 package from 1.5.5.6 to 1.7.x (or at least 1.6.6.x) but this would cause problems for those upgrading from RHEL5 to RHEL6.  There are a significant number of bugs fixed since 1.6.5.2 (see the release notes for details¹).  There is one feature of 1.6.6 and above that stands out IMO as making it a worthy update, "smart" http support.  This allows push and pull via http without the penalty of older versions versus using the git protocol.

Git generally moves fairly fast, and maintains stability well.  Shipping RHEL6 with a version that's already 6 months old will make it seem pretty old right out of the gate.

Thanks,
An EPEL-5 git maintainer

¹ http://www.kernel.org/pub/software/scm/git/docs/
Comment 2 Josh 2010-04-26 12:54:49 EDT
I would like to see this updated to 1.7 for RHEL6.
Thanks!
Comment 3 RHEL Product and Program Management 2010-04-26 13:16:55 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Nikola Pajkovsky 2010-05-04 08:22:23 EDT
Me too.

Thanks.
Comment 5 Todd Zullinger 2010-06-03 14:32:10 EDT
If it helps at all, I built 1.7.1 packages for EL-5 and EL-6 a few weeks back.

http://tmz.fedorapeople.org/packages/epel/
Comment 8 Josh 2010-06-10 09:20:18 EDT
By becoming assigned does that mean git 1.7 will be available in RHEL6 at some point?

Thanks!
Comment 9 Denise Dumas 2010-06-10 09:25:35 EDT
This bz is approved - it has 3 acks (not sure if you can see them). The acks, rather than being assigned, say that it will show up in RHEL6 (barring some unforeseen/catastrophic bug).
Comment 10 Adam Tkac 2010-06-10 10:14:05 EDT
(In reply to comment #8)
> By becoming assigned does that mean git 1.7 will be available in RHEL6 at some
> point?

I just built git-1.7.1-1.el6 which will appear in RHEL 6.
Comment 13 releng-rhel@redhat.com 2010-11-10 15:28:39 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.