Bug 586033 - After upgrade to 5.5, cannot find filesystem /dev/root on bootup (yaboot)
After upgrade to 5.5, cannot find filesystem /dev/root on bootup (yaboot)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.5
powerpc Linux
low Severity high
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 12:52 EDT by Ray Van Dolson
Modified: 2011-10-21 19:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-21 19:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel boot messages. (15.53 KB, text/plain)
2010-04-26 12:52 EDT, Ray Van Dolson
no flags Details

  None (edit)
Description Ray Van Dolson 2010-04-26 12:52:00 EDT
Created attachment 409232 [details]
Kernel boot messages.

Description of problem:
Have a two node GFS2 cluster running RHEL 5.4+errata.  I recently upgrade one node to 5.5 and rebooted.

Near the end of the bootup process, I see the following:

mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!
 <0>Rebooting in 180 seconds..

Version-Release number of selected component (if applicable):
kernel-2.6.18-194.el5
mkinitrd.5.1.19.6-61.ppc64
mkinitrd.5.1.19.6-61.ppc

How reproducible:
Always

Steps to Reproduce:
1. Boot from kernel-2.6.18-194.el5
  
Actual results:
Unable to mount /dev/root

Expected results:
System boots normally.

Additional info:
I had been running a dev kernel from support on this cluster: kernel-2.6.18-185.el5.  This kernel boots up fine (with the rest of the RHEL 5.5 userspace).

The hardware is a JS20 POWER blade.  We are attaching to two FC LUN's with multipath -- but the OS is installed on a local IDE disk.

"root" in the yaboot.conf file references the LV path.
Comment 1 Ray Van Dolson 2010-04-26 12:52:36 EDT
yaboot.conf:

# yaboot.conf generated by anaconda

boot=/dev/hda1
init-message=Welcome to Red Hat Enterprise Linux Server!\nHit <TAB> for boot options

partition=2
timeout=80
install=/usr/lib/yaboot/yaboot
delay=5
enablecdboot
enableofboot
enablenetboot
nonvram
fstype=raw

image=/vmlinuz-2.6.18-194.el5
	label=2.6.18-194.el5
	read-only
	initrd=/initrd-2.6.18-194.el5.img
	root=/dev/VolGroup00/LogVol00
	append="console=hvc0"

image=/vmlinuz-2.6.18-185.el5
	label=2.6.18-185.el5
	read-only
	initrd=/initrd-2.6.18-185.el5.img
	root=/dev/VolGroup00/LogVol00
	append="console=hvc0"
Comment 2 Ray Van Dolson 2010-04-26 12:53:49 EDT
I filed this against mkinitrd since it seemed other "similar" bugs (though none on POWER) were related to it.  Perhaps it's the kernel though.
Comment 3 Ray Van Dolson 2010-04-26 13:36:03 EDT
Please close as NOTABUG per http://kbase.redhat.com/faq/docs/DOC-29361

Note You need to log in before you can comment on or make changes to this bug.