Bug 58608 - %if statements in current sendmail spec file are wrong
%if statements in current sendmail spec file are wrong
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: sendmail (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-21 12:20 EST by Jonathan Kamens
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 12:20:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-01-21 12:20:10 EST
With rpm-4.0.4-0.12, the current Raw Hide sendmail builds wrong.  This is
because the checks against %{errata} and %{release} in sendmail.spec use quotes,
thus turning the things being compared from numbers into strings, and although
the *string* "100" is less than the *string* "70", for example, the *number* 100
is greater, and that's the behavior that was intended by the %if statements.

All the quotation marks in the %if statements in the spec file should be
removed.
Comment 1 Florian La Roche 2002-02-18 12:09:47 EST
Fixed in current version.

Thanks for this bug-report,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.