Bug 586107 - include ConvexDecomposition library
include ConvexDecomposition library
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bullet (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Kowaliczek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 16:00 EDT by Dan Horák
Modified: 2010-11-04 19:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: bullet-2.77-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-04 19:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to enhance the package (13.01 KB, patch)
2010-10-14 16:09 EDT, Dan Horák
no flags Details | Diff

  None (edit)
Description Dan Horák 2010-04-26 16:00:54 EDT
Please include the ConvexDecomposition library from Bullet Extras in the package. It required by the ogrebullet bindings library I am packaging.

I will try to prepare a patch for the bullet spec file.
Comment 1 Thomas Kowaliczek 2010-04-26 17:13:56 EDT
If you can give me an patch that would be nice.
Comment 2 Thomas Kowaliczek 2010-07-25 20:50:08 EDT
Any new here?
Comment 3 Dan Horák 2010-07-26 02:48:25 EDT
bullet 2.77 is out for few so I need some time to dig into it, if I remember some issues were fixed in the subversion trunk in the time of these reports.
Comment 4 Dan Horák 2010-07-26 03:02:43 EDT
Hm, seems that the 2.77 archive wasn't probably the final archive ...
Comment 5 Thomas Kowaliczek 2010-10-01 08:31:05 EDT
bullet 2.77 is now final out.
Comment 6 Dan Horák 2010-10-08 12:11:33 EDT
I will merge my changes with the 2.77-2 during the weekend and post the spec & co here.
Comment 7 Dan Horák 2010-10-14 16:09:23 EDT
Created attachment 453548 [details]
patch to enhance the package

Subject: [PATCH] package additional libs

- strip only problematic sources from original source archive
- add extras/extras-devel subpackage with ConvexDecomposition and GLUI libraries
- install headers into /usr/include/bullet, pkgconfig returns the right path when asked for CFLAGS
- don't list dirs and files with headers, use whole dir instead
Comment 8 Dan Horák 2010-10-14 16:10:15 EDT
I can commit the updates if you agree with them.
Comment 9 Thomas Kowaliczek 2010-10-15 09:36:27 EDT
You can do it.

Maybe you can help me with that bug here: https://bugzilla.redhat.com/show_bug.cgi?id=642332

Because i don´t know if it will break something?
Comment 10 Thomas Kowaliczek 2010-10-19 22:34:44 EDT
Dan Horák when will you update bullet with your patch?
Comment 11 Dan Horák 2010-10-20 04:25:16 EDT
committed and built in rawhide only, please do a merge into f14 if you want to keep rawhide and f14 in sync
Comment 12 Fedora Update System 2010-10-20 18:19:01 EDT
bullet-2.77-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bullet-2.77-3.fc14
Comment 13 Fedora Update System 2010-10-28 02:09:00 EDT
bullet-2.77-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bullet'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bullet-2.77-3.fc14
Comment 14 Fedora Update System 2010-11-04 19:44:47 EDT
bullet-2.77-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.