Bug 586111 - Can't login with external monitor
Can't login with external monitor
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 16:05 EDT by Nikolai Maziashvili
Modified: 2010-04-30 06:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 14:45:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolai Maziashvili 2010-04-26 16:05:19 EDT
Description of problem:
This only holds for KDE F13 beta install.
I got 24" monitor that i connect to netbook using VGA cable. When i boot laptop i get dual screen situation - it's where i can drag mouse pointer across both (laptop and 24" external) monitors. When i press Fn-F7 combination i export screen to only 24" external monitor. then i try to login, then it looks like desktop starts to initialize but then screen blinks and i'm at login prompt all over again.
Under Gnome it works just fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always 

Steps to Reproduce:
1. Clean install F13 beta KDE
2. Plug VGA to netbook and boot
3. Try with Fn-F7 key combination export screen to external monitor
  
Actual results:
It is impossible even to login into system

Expected results:
Working environment on external 24" moniitor

Additional info:
Some hard-/software specs:

- netbook Sony vaio VPCW21S1E, CPU Intel Nano450, GPU integrated Intel 3150
- Fedora 13 beta
Comment 1 Nikolai Maziashvili 2010-04-26 19:38:40 EDT
I found out that when desktop effects are turned off then everything goes fine. But moment i turn desktop effects on everything goes wrong again.
Comment 2 Adam Jackson 2010-04-29 14:45:38 EDT
3D doesn't work on gen3 parts (915, 945, G33, or Nano) at display widths greater than 2048.  This is a hardware limitation, not something the driver can fix.
Comment 3 Nikolai Maziashvili 2010-04-30 06:50:45 EDT
Hi Adam,

I do not quite understand. I do not have monitor with resolution greater then 2048. My monitor is 1920x1200 pixels and if i logged in and then enable 3D then everything works just fine.
I realize that might sound strange especially when even Sony website says in techspecs of this particular laptop that external monitor greater then 1920x1050 is not supported.
Bu the fact is - it does support my (higher resolution) monitor and 3D is working with every kind of effect enabled in settings.
Only things is i have to have it disabled before i log in to system.

Please share your thoughts about this.
I'm not gonna reopen ticket, because i can be overseeing something.

Note You need to log in before you can comment on or make changes to this bug.