Bug 586113 - [abrt] crash in meld-1.3.1-1.fc13: meldapp.py:645:on_menu_quit_activate:RuntimeError: called outside of a mainloop
[abrt] crash in meld-1.3.1-1.fc13: meldapp.py:645:on_menu_quit_activate:Runti...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
abrt_hash:c0166d23
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 16:09 EDT by Pavel Alexeev
Modified: 2011-03-22 18:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-22 18:43:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (562 bytes, text/plain)
2010-04-26 16:09 EDT, Pavel Alexeev
no flags Details

  None (edit)
Description Pavel Alexeev 2010-04-26 16:09:07 EDT
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: python /usr/bin/meld without_morelink without_picture with_morelink
comment: Do 3-side diff
component: meld
executable: /usr/bin/meld
kernel: 2.6.33.1-24.fc13.i686
package: meld-1.3.1-1.fc13
reason: meldapp.py:645:on_menu_quit_activate:RuntimeError: called outside of a mainloop
release: Fedora release 13 (Goddard)

backtrace
-----
meldapp.py:645:on_menu_quit_activate:RuntimeError: called outside of a mainloop

Traceback (most recent call last):
  File "/usr/share/meld/meldapp.py", line 585, in on_delete_event
    return self.on_menu_quit_activate()
  File "/usr/share/meld/meldapp.py", line 645, in on_menu_quit_activate
    gtk.main_quit()
RuntimeError: called outside of a mainloop

Local variables in innermost frame:
self: <meldapp.MeldApp object at 0x9d11f8c>
c: <gtk.VBox object at 0x9d193ec (GtkVBox at 0x9d51978)>
response: <enum GTK_RESPONSE_OK of type GtkResponseType>
extra: ()
Comment 1 Pavel Alexeev 2010-04-26 16:09:10 EDT
Created attachment 409279 [details]
File: backtrace
Comment 2 Fedora Admin XMLRPC Client 2011-03-13 11:38:40 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Dominic Hopf 2011-03-22 18:43:57 EDT
Thanks very much for reporting the issue. Please try updating to a more current version of meld and/or Fedora and have a look if the issue is still reproducible there.

Note You need to log in before you can comment on or make changes to this bug.