Bug 586116 - add descriptions of columns to pmap(1) man page
add descriptions of columns to pmap(1) man page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: procps (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Görig
BaseOS QE - Apps
:
Depends On:
Blocks: 598054
  Show dependency treegraph
 
Reported: 2010-04-26 16:22 EDT by Jeff Bastian
Modified: 2013-04-12 16:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: procps-3.2.7-17.el5
Doc Type: Bug Fix
Doc Text:
Cause pmap manual page doesn't describe displayed columns Consequence user doesn't know what each column means Fix manual page update Result columns are described in manual page
Story Points: ---
Clone Of:
: 598054 (view as bug list)
Environment:
Last Closed: 2011-04-20 09:26:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0459 normal SHIPPED_LIVE procps bug fix update 2011-04-20 09:25:35 EDT

  None (edit)
Description Jeff Bastian 2010-04-26 16:22:49 EDT
Description of problem:
Please add a short description of the columns shown in the 'pmap -x' output.  Some columns are self-explanatory like Address and KBytes, but RSS and Dirty may not be quite as obvious if you're not familiar with Linux virtual memory terminology.

Columns include Address, Kbytes, RSS, Dirty, Mode, and Mapping

Version-Release number of selected component (if applicable):
procps-3.2.7-16.el5
Comment 1 Jeff Bastian 2010-04-26 16:44:51 EDT
Possible definitions for pmap(1) man page:

Address: start address of map
Kbytes: size of map in kilobytes
RSS: resident set size in kilobytes
Dirty: dirty pages (both shared and private) in kilobytes
Mode: permissions on map: read, write, execute, shared, private (copy on write)
Mapping: file backing the map, or '[ anon ]' for allocated memory, or  '[ stack ]' for the program stack

See proc(5) man page for more details.
Comment 5 RHEL Product and Program Management 2010-08-09 14:26:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 Jan Görig 2011-03-17 06:22:47 EDT
Fixed in procps-3.2.7-17.el5.
Comment 9 Jan Görig 2011-03-17 08:47:33 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
  pmap manual page doesn't describe displayed columns
Consequence
  user doesn't know what each column means
Fix
  manual page update
Result
  columns are described in manual page
Comment 10 Branislav Náter 2011-04-11 11:09:03 EDT
Fix was tested on package procps-3.2.7-17.el5.

Manual page now contains description of column names.
Comment 11 errata-xmlrpc 2011-04-20 09:26:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0459.html

Note You need to log in before you can comment on or make changes to this bug.