Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 586118 - space bar no longer seems to page down
space bar no longer seems to page down
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 16:31 EDT by James Antill
Modified: 2010-04-28 13:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 13:06:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 575038 None None None Never

  None (edit)
Description James Antill 2010-04-26 16:31:16 EDT
Description of problem:
 If I click on an email and press spacebar, it doesn't scroll the preview pane anymore.

Version-Release number of selected component (if applicable):
Installed Packages
evolution.x86_64                 2.30.0-3.fc13                  @updates-testing
Comment 1 Milan Crha 2010-04-27 04:54:34 EDT
Thanks for a bug report. I cannot reproduce it, somehow, with just released evolution-2.30.1, the spacebar is scrolling the message regardless where I am (the message list, or the message itself in the preview pane below the message list, or even in the message window) and whether I have or haven't checked Edit->Preferences->Mail Preferences->Enable Magic Spacebar.

Could you try with 2.30.1, please? (Note there will be a release of 2.30.1-2 due to missing icons, but that should be unrelated to this bug.)
Comment 2 James Antill 2010-04-27 10:09:36 EDT
 Nope still doesn't work here:

Installed Packages
evolution.x86_64                     2.30.1-1.fc13          @updates-testing
evolution-data-server.x86_64         2.30.1-1.fc13          @updates-testing
evolution-help.noarch                2.30.1-1.fc13          @updates-testing
evolution-perl.x86_64                2.30.1-1.fc13          @updates-testing

...also tried vertical view, but that did the same thing (nothing).
 I checked and Enable Magic Spacebar is still enabled.

 I ran xev and hit spacebar:

KeyPress event, serial 30, synthetic NO, window 0x5e00001,
    root 0x107, subw 0x0, time 207970931, (1316,491), root:(1326,570),
    state 0x0, keycode 65 (keysym 0x20, space), same_screen YES,
    XLookupString gives 1 bytes: (20) " "
    XmbLookupString gives 1 bytes: (20) " "
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x5e00001,
    root 0x107, subw 0x0, time 207971003, (1316,491), root:(1326,570),
    state 0x0, keycode 65 (keysym 0x20, space), same_screen YES,
    XLookupString gives 1 bytes: (20) " "
    XFilterEvent returns: False
Comment 3 Milan Crha 2010-04-28 08:24:31 EDT
which part of evolution is selected when you hit the space bar?

Say when you select a message preview panel, (thus pressing arrows up and down will scroll the message content) will the space bar do anything?

Do you have View->Caret Mode on or off? I have it off. I vaguely recall some bug reports that the magic space bar doesn't work with the caret mode, so maybe it's the issue?
Comment 4 James Antill 2010-04-28 09:56:13 EDT
> Do you have View->Caret Mode on or off? I have it off. I vaguely recall some
> bug reports that the magic space bar doesn't work with the caret mode, so maybe
> it's the issue?    

 I have it on, and yeh that was it. Magic space bar is more important than caret mode, so I toggled that and it worked again ... thanks.

 I'll leave this open, as they both worked in F-12 ... but feel free to close to an upstream BZ or whatever as I'm happy ;).
Comment 5 Milan Crha 2010-04-28 13:06:38 EDT
Thanks for the update. There is really an upstream bug [1], thus I'm moving this one there.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=575038

Note You need to log in before you can comment on or make changes to this bug.