Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 586163 - Job matrix report ISE
Summary: Job matrix report ISE
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Retired
Component: web UI
Version: 0.5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 00:33 UTC by Raymond Mancy
Modified: 2019-05-22 13:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-28 20:04:26 UTC


Attachments (Terms of Use)

Description Raymond Mancy 2010-04-27 00:33:13 UTC
Description of problem:

ISE in matrix report

Version-Release number of selected component (if applicable):


How reproducible:

consistent

Steps to Reproduce:
1.Go to matrix report
2. Put in '1 2 3 4 5 6 7' in the Job IDS section
3. click generate
  
Actual results:
*BOOM*

Expected results:

Generated matrix report

Additional info:

This problem is caused because of the Turbogears DataGrid object. It dies if you give two columns in a table the same name. It sometimes happens that there are two recipes with the same name under one distro. This constitues two columns with the same name in one table.

Comment 1 Raymond Mancy 2010-04-27 21:24:48 UTC
This was fixed yesterday and pushed to bz586163

Comment 2 Bill Peck 2010-04-28 20:04:26 UTC
merged and pushed live.  Thanks Ray.


Note You need to log in before you can comment on or make changes to this bug.