Bug 586173 - qemu monitor always use read-write type for the changed cd
qemu monitor always use read-write type for the changed cd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: chellwig@redhat.com
Virtualization Bugs
: Triaged
: 641854 657252 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-04-26 22:31 EDT by Miya Chen
Modified: 2013-01-09 17:30 EST (History)
11 users (show)

See Also:
Fixed In Version: kvm-83-225.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 04:50:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miya Chen 2010-04-26 22:31:44 EDT
Description of problem:


Version-Release number of selected component (if applicable):
# uname -r
2.6.18-194.el5
# rpm -q kvm
kvm-83-171.el5


How reproducible:
100%

Steps to Reproduce:
1.start guest:
# /usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -drive
file=rhel5.5-64-virtio.qcow2,media=disk,if=virtio,boot=on,cache=off,index=0,werror=stop
-smp 1 -m 1G -cpu qemu64,+sse2 -vnc :31 -monitor stdio -net
nic,vlan=0,macaddr=20:20:28:90:68:80,model=e1000 -net
tap,vlan=0,script=/etc/qemu-ifup -boot c -drive
file=test_read.qcow2,if=virtio,media=disk,werror=stop,readonly=on

2.
(qemu) eject ide1-cd0
(qemu) change ide1-cd0 gpxe.iso 
(qemu) info block

Actual results:
ide1-cd0: type=cdrom removable=1 locked=0 file=gpxe.iso ro=0 drv=raw  

Expected results:
ide1-cd0: type=cdrom removable=1 locked=0 file=gpxe.iso ro=1 drv=raw  

Additional info:
Comment 2 Jiri Denemark 2010-10-22 09:11:58 EDT
*** Bug 641854 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Denemark 2010-10-22 09:14:05 EDT
Note, this is actually preventing the media to be changed at all using libvirt if selinux is in enforcing mode so this would probably deserve higher priority.
Comment 4 Dor Laor 2010-10-24 06:59:44 EDT
Markus, what's your view of it? Is it complex to fix?
Comment 7 RHEL Product and Program Management 2011-01-11 15:52:32 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-01-11 17:50:54 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 9 Markus Armbruster 2011-01-14 11:08:04 EST
Probably related to rhel-6 bug 602026.
Comment 10 Jes Sorensen 2011-01-17 06:14:24 EST
Move to Tier2 to match tier of 602026
Comment 11 Jes Sorensen 2011-01-17 08:15:01 EST
Reassign to Christoph as he did the RHEL6 patch for this one.

Christoph, please take a quick look and apply the same RHEL5.7
triage rules to this one.

Thanks,
Jes
Comment 12 chellwig@redhat.com 2011-01-17 10:20:32 EST
It's easily doable for RHEL5.7.  I've just posted the patch for review.
Comment 17 FuXiangChun 2011-05-13 01:46:06 EDT
Reproduced on kvm-83-224.el5
Verified on kvm-83-232.el5

Steps to Reproduce:
1.run a VM 
2.info block and check ide1-cd0 status
3.eject ide1-cd0
4 change ide1-cd0 filename and check ide1-cd0's status

Actual Results:
on kvm-83-224.el5 ,ide1-cd0 ro=0
on kvm-83-232.el5 ,ide1-cd0 ro=1

Based on above ,this issue has been fixed.
Comment 18 Miroslav Grepl 2011-05-19 11:34:45 EDT
*** Bug 657252 has been marked as a duplicate of this bug. ***
Comment 20 errata-xmlrpc 2011-07-21 04:50:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1068.html
Comment 21 errata-xmlrpc 2011-07-21 07:48:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1068.html

Note You need to log in before you can comment on or make changes to this bug.