Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 586188 - /tmp/netinfo no longer available during kickstart for %pre/%post scripts
/tmp/netinfo no longer available during kickstart for %pre/%post scripts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ruediger Landmann
ecs-bugs
: Documentation
: 594557 (view as bug list)
Depends On:
Blocks: 594557 594558
  Show dependency treegraph
 
Reported: 2010-04-26 23:22 EDT by Don Hoover
Modified: 2010-11-11 10:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Anaconda now utilizes NetworkManager for network interface configuration. Consequently, kickstart users that referenced the network settings located in /tmp/netinfo must now source the ifcfg files found in /etc/sysconfig/network-scripts
Story Points: ---
Clone Of:
: 594557 594558 (view as bug list)
Environment:
Last Closed: 2010-11-11 10:33:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Hoover 2010-04-26 23:22:03 EDT
Description of problem:
Apparently the /tmp/netinfo file is no longer created by anaconda.  This was a widely documented place since RH7.x days to get the current network settings during %pre/%post scripts in kickstarts.  I see from the anaconda dev list that this was removed sometime during FC12 without much discussion.  

This should be documented in the Release Notes probably since it was such as very popular thing to do during kickstart scripts.  

It was a handy way to copy the network settings obtained via DHCP into your kickstart via a %include.


Version-Release number of selected component (if applicable):
EL6 Beta 1

How reproducible:
/tmp/netinfo file no longer created by anaconda

Steps to Reproduce:
1. %pre script in kickstart
2. cat /tmp/netinfo
3. file does not exist
  
Actual results:
File would exist and have current network settings in an easily parseable format.

Expected results:


Additional info:

Is there a replacement for this functionality outside of just replacing the parsing of the /tmp/netinfo file with a bunch more code to gather it manually via ifconfig etc?  

Otherwise this should be a good note to put into the EL6 release notes.
Comment 2 RHEL Product and Program Management 2010-04-27 00:25:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 David Cantrell 2010-04-27 09:48:58 EDT
This is not a bug, but something we need to note in the release notes.

Ryan, what state should I leave the bug in since this is just a release notes issue?  What flags should I have set?
Comment 4 David Cantrell 2010-04-27 09:48:58 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Kickstarts users will find that /tmp/netinfo is no longer available under RHEL 6.0.  Anaconda is now using NetworkManager for network interface configuration.  Rather than looking at /tmp/netinfo for network settings used during installation, users can source the ifcfg files found in /etc/sysconfig/network-scripts, just like on a running system.
Comment 6 Ryan Lerch 2010-05-20 22:38:06 EDT
*** Bug 594557 has been marked as a duplicate of this bug. ***
Comment 7 Ryan Lerch 2010-05-20 22:55:59 EDT
added as a known issue to the Beta2 Release Notes.
http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Beta_2_Release_Notes/
Comment 8 Ryan Lerch 2010-05-20 22:55:59 EDT
Technical note updated. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-Kickstarts users will find that /tmp/netinfo is no longer available under RHEL 6.0.  Anaconda is now using NetworkManager for network interface configuration.  Rather than looking at /tmp/netinfo for network settings used during installation, users can source the ifcfg files found in /etc/sysconfig/network-scripts, just like on a running system.+Anaconda now utilizes NetworkManager for network interface configuration. Consequently, kickstart users that referenced the network settings located in /tmp/netinfo must now source the ifcfg files found in /etc/sysconfig/network-scripts
Comment 9 Ruediger Landmann 2010-06-23 02:29:04 EDT
Added as an admonition in "32.1. What are Kickstart Installations?" from build 0-67 onwards:

"Note — /tmp/netinfo no longer used
Anaconda now configures network interfaces with NetworkManager. Consequently, kickstart users that referenced the network settings located in /tmp/netinfo in previous versions of Red hat Enterprise Linux must now source the ifcfg files in /etc/sysconfig/network-scripts. "

(this admonition follows the description of /tmp as the location to which scriptlets and log files are saved)
Comment 10 Michael Doyle 2010-07-04 20:07:01 EDT
Verified it is in Red_Hat_Enterprise_Linux-Installation_Guide-6-en-US-0-74.
Comment 11 releng-rhel@redhat.com 2010-11-11 10:33:42 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.