Bug 586191 - Latest NetworkManager unable to connect
Latest NetworkManager unable to connect
Status: CLOSED DUPLICATE of bug 538499
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 23:32 EDT by Scott Schmit
Modified: 2010-04-27 03:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 03:09:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages after the reboot (NM 0.8...) (10.81 KB, application/octet-stream)
2010-04-26 23:32 EDT, Scott Schmit
no flags Details
The logs after I was able to downgrade NetworkManager (13.06 KB, text/plain)
2010-04-26 23:33 EDT, Scott Schmit
no flags Details

  None (edit)
Description Scott Schmit 2010-04-26 23:32:42 EDT
Created attachment 409341 [details]
/var/log/messages after the reboot (NM 0.8...)

Description of problem:
After updating to the latest NetworkManager, it is no longer able to connect.

Version-Release number of selected component (if applicable):
1:0.8.0-6.git20100408.fc12.x86_64

How reproducible:
For me, it fails 99% of the time. On a friend's laptop, it works fine.

Steps to Reproduce:
1. Update to the latest version, have a system connection, reboot
2. Log in, notice that the applet is still indicating that NetworkManager is still trying to connect
3. 
  
Actual results:
NetworkManager never declared success.
ip addr shows that all the IPv6 addresses have been configured, but IPv4 address from DHCP has not been assigned, there is no route, and /etc/resolv.conf is empty.

Expected results:
It connects successfully, of course.

Additional info:
My network driver is iwlagn (but so's my friend's). This is a Dell Studio 1537 (my friend's is a Dell Studio 1555).

I don't know if it's specific to wireless or if it's networking in general. When I looked at the /var/log/messages, I saw that NetworkManager appeared to get and recognize a response from the dhcp server, but it didn't actually assign the address (or not for very long). I'll post the extract as an attachment.
Comment 1 Scott Schmit 2010-04-26 23:33:47 EDT
Created attachment 409342 [details]
The logs after I was able to downgrade NetworkManager
Comment 2 Dan Williams 2010-04-27 03:09:24 EDT
This is more of a symptom of some larger IPv6 bugs that were recently fixed...

*** This bug has been marked as a duplicate of bug 538499 ***

Note You need to log in before you can comment on or make changes to this bug.