Bug 58620 - kernel oops in ip_conntrack
kernel oops in ip_conntrack
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-21 12:51 EST by Michael Young
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 06:53:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from ksymoops (9.69 KB, text/plain)
2002-01-21 12:53 EST, Michael Young
no flags Details
ksymoops from 2.4.9-21enterprise (7.24 KB, text/plain)
2002-01-30 05:53 EST, Michael Young
no flags Details

  None (edit)
Description Michael Young 2002-01-21 12:51:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I have a couple of machines running squid under fairly heavy loads, which are
crashing every day or so (system freezes completely - requiring a power cycle).
The systems have 2 1Ghz processors, running 2.4.9-13enterprise using iptables. I
have now obtained a full stack trace from a serial console, and attach the
output from ksymoops. This  seems to point to a problem in ip_conntrack.

Version-Release number of selected component (if applicable): 2.4.9-13enterprise


How reproducible:
Always

Steps to Reproduce:
1.run squid under a heavy load
2.wait
	

Additional info:
Comment 1 Michael Young 2002-01-21 12:53:13 EST
Created attachment 43034 [details]
Output from ksymoops
Comment 2 Michael Young 2002-01-30 05:50:52 EST
The problem is still in 2.4.9-21enterprise, though the crash was slightly
different this time (see new attachment). If I change the firewall so it doesn't
use connection tracking (and make sure ip_conntrack and dependent modules aren't
loaded) then 2.4.9-13enterprise seems to be stable. I also tried a mainline
kernel 2.4.18-pre6 (based on the enterprise config from 2.4.9-13) and this seems
to be stable with connection tracking active.
Comment 3 Michael Young 2002-01-30 05:53:15 EST
Created attachment 43980 [details]
ksymoops from 2.4.9-21enterprise
Comment 4 Michael Young 2003-01-13 06:53:11 EST
This problem went away in the 2.4.18-* kernels in 7.3

Note You need to log in before you can comment on or make changes to this bug.