Bug 586217 - Sysstat package no longer collects disk statistics by default
Sysstat package no longer collects disk statistics by default
Status: CLOSED DUPLICATE of bug 598794
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sysstat (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Ivana Varekova
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 01:09 EDT by Pat Kartas
Modified: 2011-03-02 12:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-24 02:02:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pat Kartas 2010-04-27 01:09:16 EDT
Description of problem:
sadc was adjusted from v5.1.2 (RHEL5 uses v7+) to only collect disk stats if the '-d' flag is set, to save disk space. This is unlikely to be desired behaviour for an enterprise OS, and not something sysadmins should need to remember to turn on by default. The fix is trivial: to adjust the /etc/cron.d/sysstat entry for sa1 to include a '-d' flag.

Version-Release number of selected component (if applicable):
7.0.2


How reproducible:
Always

Steps to Reproduce:
1. Install sysstat package, and allow stats collection to begin to run

2. Run
$ sar -d

3. Compare with
$ sar -d 1 1
  

Actual results:
"Requested activities not available in file"


Expected results:
"Linux 2.6.18-164.el5 (bfssydc9n1)       04/27/10

15:01:56          DEV       tps  rd_sec/s  wr_sec/s  avgrq-sz  avgqu-sz     await     svctm     %util
15:01:57       dev8-0      0.00      0.00      0.00      0.00      0.00      0.00      0.00      0.00
15:01:57       dev8-1      0.00      0.00      0.00      0.00      0.00      0.00      0.00      0.00
15:01:57       dev8-2      0.00      0.00      0.00      0.00      0.00      0.00      0.00      0.00
..."


Additional info:
Can be fixed with e.g.
bfssydc8n1 root[95] diff /var/tmp/sysstat.crond.orig /etc/cron.d/sysstat
2c2
< */10 * * * * root /usr/lib64/sa/sa1 1 1
---
> */10 * * * * root /usr/lib64/sa/sa1 -d 1 1
Comment 1 Greg A 2010-08-19 19:10:41 EDT
I'm chiming in to state that as a large enterprise customer, we COMPLETELY agree.  Disk statistics are absolutely mandatory in our environment.

I've also asked our TAM to push this through along with an enhancement request for SAR to provide the disk statistics by sd or mpath device names.  As they report today they are difficult to interrupt because we have to map the contents of /proc/partitions (major minor numbers) back to the sd or multipath device.

I'd like the -d added in 5.6 and any new major release. I'd like the enhancement mapped into a future update of sysstat on RHEL 5 as well as RHEL 6.
Comment 3 Ivana Varekova 2011-01-24 02:02:50 EST

*** This bug has been marked as a duplicate of bug 598794 ***

Note You need to log in before you can comment on or make changes to this bug.