Bug 58624 - lists inside para produce incorrect troff
Summary: lists inside para produce incorrect troff
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xmlto   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Tim Waugh
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-21 19:06 UTC by Tammy Fox
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 19:10:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tammy Fox 2002-01-21 19:06:06 UTC
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Tammy Fox 2002-01-21 19:10:07 UTC
Sorry. Apparently pressing enter in the summary text field submits the bug!

Anyway, having

<para>
	  Exceptions are represented in two ways: 


	<itemizedlist>
	  <listitem>
	    <para>As a single bit (exception present/absent) with these bits
	      corresponding in some implementation-defined way with bit
	      positions in an integer.</para>
	  </listitem>
	</itemizedlist>
	  
	<itemizedlist>
	  <listitem>
	    <para>As an opaque structure that may contain more information            about
	      the exception (for example, the code address where it occurred).</para>
	  </listitem>
	</itemizedlist>

	</para>	

produces 

Exceptions are represented in two ways: .TP 3 \(bu As a single bit (exception
present/absent) with these bits corresponding in some implementation-defined way
with bit positions in an integer. .LP .TP 3 \(bu As an opaque structure that may
contain more information about the exception (for example, the code address
where it occurred). .LP




Comment 2 Tim Waugh 2002-01-21 22:58:49 UTC
Should be fixed in xmlto-0.0.7-1, although it's kinda hacky.  I can't think of 
a _good_ way of fixing it.  Do the lists have to be inside the paras?


Comment 3 Tammy Fox 2002-01-22 00:03:28 UTC
Lists don't have to be inside paras, but since it is a valid markup
I thought it should be fixed. In general, lists should not be
put inside paras because it leaves unnecessary white space in
the PS/PDF output.


Note You need to log in before you can comment on or make changes to this bug.