Bug 586286 - smc-kalyani-fonts isn't usable
smc-kalyani-fonts isn't usable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smc-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Naveen Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 586891
  Show dependency treegraph
 
Reported: 2010-04-27 04:51 EDT by Akira TAGOH
Modified: 2010-07-30 04:36 EDT (History)
8 users (show)

See Also:
Fixed In Version: smc-fonts-4.4-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586891 (view as bug list)
Environment:
Last Closed: 2010-07-29 01:54:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TTF of Dyuthi Version 1.0.1 (203.31 KB, application/x-font-ttf)
2010-04-30 13:50 EDT, Hiran Venugopalan
no flags Details
Kalyani. Bug fixed (81.78 KB, application/x-font-ttf)
2010-04-30 14:46 EDT, Hiran Venugopalan
no flags Details

  None (edit)
Description Akira TAGOH 2010-04-27 04:51:05 EDT
Description of problem:
smc-kalyani-fonts is supposed to work for Malayalam font though, it doesn't have enough glyph coverage in fontconfig.

Version-Release number of selected component (if applicable):
smc-kalyani-fonts-04.2-7.fc13.noarch

How reproducible:
always

Steps to Reproduce:
1.fc-match -v "Kalyani"|grep -E "        lang"|grep ml
2.
3.
  
Actual results:
No output

Expected results:
the lang spec should contains ml.

Additional info:
Comment 1 Naveen Kumar 2010-04-29 08:11:56 EDT
The unicode values of U+0D60 & U+0D61 specified in ml.orth are missing in this font and hence script/language requirement is not fulfilled.
 
Adding glyphs for U+0D60 & U+0D61 would solve this problem.
Comment 2 Hiran Venugopalan 2010-04-30 13:50:52 EDT
Created attachment 410557 [details]
TTF of Dyuthi Version 1.0.1

Dyuthi with U+ODOC.
Full font. Not patch.
Comment 3 Hiran Venugopalan 2010-04-30 14:46:48 EDT
Created attachment 410569 [details]
Kalyani. Bug fixed

The last upload was mistake. Sorry.
Attached TTF of Kalyani with 0d60 and 0d61
Comment 4 Naveen Kumar 2010-05-03 03:06:15 EDT
(In reply to comment #3)
> Created an attachment (id=410569) [details]
> Kalyani. Bug fixed
> 
> The last upload was mistake. Sorry.
> Attached TTF of Kalyani with 0d60 and 0d61    

Thanks Hiran :) Just wanted to ask will this be fixed in upstream too...
Comment 5 Pravin Satpute 2010-05-03 04:24:59 EDT
(In reply to comment #3)
> Created an attachment (id=410569) [details]
> Kalyani. Bug fixed
> 
> The last upload was mistake. Sorry.
> Attached TTF of Kalyani with 0d60 and 0d61    

Thanks for fix

can you update version inside fonts as well
1) Elements-> Font Information -> Names and in
2) Elements-> Font Information -> TTF names as well?

previous version was 1.3
so i think this can be 1.3.1
Comment 6 Akira TAGOH 2010-07-13 04:29:34 EDT
Any plans to push the updates and get this fixed in?
Comment 7 Naveen Kumar 2010-07-13 04:50:14 EDT
Upstream has informed me that they are doing some enhancement work. Therefore, I have to wait till they finish. But probably, I would be able to finish it by this weekend.
Comment 8 Fedora Update System 2010-07-16 05:23:11 EDT
smc-fonts-4.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/smc-fonts-4.4-1.fc13
Comment 9 Fedora Update System 2010-07-16 14:49:36 EDT
smc-fonts-4.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smc-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/smc-fonts-4.4-1.fc13
Comment 10 Pravin Satpute 2010-07-26 07:08:58 EDT
(In reply to comment #0)
> 
> Steps to Reproduce:
> 1.fc-match -v "Kalyani"|grep -E "        lang"|grep ml

looks like some problem happens while pasting 

it should be

$fc-match -v "Dyuthi"|grep -E "lang"|grep ml
Comment 11 Naveen Kumar 2010-07-29 01:54:59 EDT
Closing the bug, if problem persists, please reopen it again.
Comment 12 Fedora Update System 2010-07-30 04:36:47 EDT
smc-fonts-4.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.