Bug 58629 - fdisk will report an error re-reading the partition table
Summary: fdisk will report an error re-reading the partition table
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-21 19:49 UTC by Rob Landry
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 21:51:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Landry 2002-01-21 19:49:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
fdisk reports error 16 on scsi drives with existing partitions when
changing/creating a partition upon exiting.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run fdisk on a scsi drive already containing partitions
2. create a new partition
3. exit fdisk
	

Actual Results:  Calling ioctl() to re-read partition table 
Re-read table failed with error 16: Device or resource busy. 
Reboot your system to ensure the partition table is updated. 

fdisk exists with an error (ie. echo $? <> 0)

Expected Results:  clean exit of fdisk with exit status of "0"

Additional info:

Comment 1 Elliot Lee 2002-01-29 21:27:32 UTC
It exits with this error because the kernel returns EBUSY for the ioctl - this
is a kernel issue (not sure if it is a bug or not).

Reassigning.

Comment 2 Arjan van de Ven 2002-01-29 21:32:03 UTC
how about some basic info?
kernel version
is anything mounted from the disk


Comment 3 Rob Landry 2002-01-29 21:51:28 UTC
Stock 7.2.  Yes other things are mounted but not the edited partition.


Comment 4 Arjan van de Ven 2002-01-29 21:54:42 UTC
editing live partition tables (eg tables where at least one partition is
mounted) is not supported and very dangerous.


Note You need to log in before you can comment on or make changes to this bug.