Bug 586294 - 3 broken dependencies in package rubygem-cucumber
3 broken dependencies in package rubygem-cucumber
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: rubygem-cucumber (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Stahnke
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 05:11 EDT by Marc Fournier
Modified: 2010-10-12 10:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-12 10:02:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Fournier 2010-04-27 05:11:05 EDT
Description of problem:

Among other, rubygem-cucumber depends on these packages:

rubygem(polyglot) >= 0.2.5
rubygem(term-ansicolor) >= 1.0.3


Both of them are currently unavailable as RPM packages in epel or rhel,
which renders rubygem-cucumber uninstallable using "yum install".


If I install them using "gem install", I get the following errors:


/usr/lib/ruby/site_ruby/1.8/rubygems.rb:636:in `report_activate_error': RubyGem version error: polyglot(0.2.5 not = 0.2.9) (Gem::LoadError)

/usr/lib/ruby/site_ruby/1.8/rubygems.rb:636:in `report_activate_error': RubyGem version error: term-ansicolor(1.0.3 not = 1.0.4) (Gem::LoadError)



Furthermore, rubygem-cucumber depends on:

rubygem(treetop) >= 1.2.5

So far so good, rubygem-treetop-1.3.0 is available in epel. But when
running cucumber I get:

/usr/lib/ruby/site_ruby/1.8/rubygems.rb:636:in `report_activate_error': RubyGem version error: treetop(1.3.0 not = 1.4.2) (Gem::LoadError)


After installing treetop-1.4.2, polyglot-0.2.9 and term-ansicolor-1.0.4 using
"gem install --version", cucumber works fine.

Finally, after having uninstalled the rubygem-cucumber RPM, I have these
gems installed (all except polyglot, term-ansicolor and treetop come from
epel/rhel RPMs):

# gem list 

*** LOCAL GEMS ***

builder (2.1.2)
diff-lcs (1.1.2)
hoe (1.8.2)
polyglot (0.2.9)
rake (0.8.3)
rubyforge (1.0.1)
term-ansicolor (1.0.4)
treetop (1.4.2)

But I am then unable to install the rubygem-cucumber RPM without using
"--nodeps":

# rpm -ivh http://download.fedora.redhat.com/pub/epel/5/x86_64/rubygem-cucumber-0.4.2-1.el5.noarch.rpm
Retrieving http://download.fedora.redhat.com/pub/epel/5/x86_64/rubygem-cucumber-0.4.2-1.el5.noarch.rpm
error: Failed dependencies:
  rubygem(polyglot) >= 0.2.5 is needed by rubygem-cucumber-0.4.2-1.el5.noarch
  rubygem(term-ansicolor) >= 1.0.3 is needed by rubygem-cucumber-0.4.2-1.el5.noarch
  rubygem(treetop) >= 1.2.5 is needed by rubygem-cucumber-0.4.2-1.el5.noarch

# rpm -ivh --nodeps http://download.fedora.redhat.com/pub/epel/5/x86_64/rubygem-cucumber-0.4.2-1.el5.noarch.rpm
Retrieving http://download.fedora.redhat.com/pub/epel/5/x86_64/rubygem-cucumber-0.4.2-1.el5.noarch.rpm
Preparing...                ########################################### [100%]
   1:rubygem-cucumber       ########################################### [100%]

# cucumber --help > /dev/null 
# echo $?
0



Version-Release number of selected component (if applicable):
rubygem-cucumber-0.4.2-1.el5.noarch.rpm


How reproducible:
Always

Additional info:

I suppose the specfile should at least be updated to contain:
rubygem(polyglot) = 0.2.9
rubygem(term-ansicolor) = 1.0.4
rubygem(treetop) = 1.4.2
Comment 1 Michael Stahnke 2010-09-15 10:00:11 EDT
Sorry for the long wait. 

Building rubygem-polyglot for EPEL 5 today.  It should be available in epel-testing tomorrow.
Comment 2 Fedora Update System 2010-09-15 10:33:08 EDT
rubygem-polyglot-0.2.5-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/rubygem-polyglot-0.2.5-4.el5
Comment 3 Michael Stahnke 2010-09-15 11:09:13 EDT
It looks like cucumber now requires term-ansicolor >= 1.0.4, which is good for EPEL 5.  Polyglot got built today.  

Hopefully this will resolve the issue shortly.
Comment 4 Fedora Update System 2010-09-30 13:08:34 EDT
rubygem-polyglot-0.2.5-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Michael Stahnke 2010-10-12 10:02:52 EDT
The problem appears to be resolved.  I am closing the issue. 

just tested on EL5.5 with EPEL.

Note You need to log in before you can comment on or make changes to this bug.