This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 586373 - intel: X-Server goes black as soon as display is added or removed. (IBM T400)
intel: X-Server goes black as soon as display is added or removed. (IBM T400)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 08:41 EDT by Felix Möller
Modified: 2010-07-28 10:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 10:43:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log of the xserver when attaching a screen (118.53 KB, text/plain)
2010-04-27 08:42 EDT, Felix Möller
no flags Details
Xorg.0.log when display goes black (217.69 KB, text/plain)
2010-05-20 14:31 EDT, Felix Möller
no flags Details

  None (edit)
Description Felix Möller 2010-04-27 08:41:09 EDT
Description of problem:
I had a perfectly working T400 with a Fedora 12 installation which I upgraded recently to F13. Now I get logged out as soon as i connect an external screen. I assume X crashes, but there is nothing in Xorg.0.log ...

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.11.0-2.fc13.i686

[fm@thinkpad ~]$ uname -a
Linux thinkpad 2.6.33.2-57.fc13.i686.PAE #1 SMP Tue Apr 20 08:58:17 UTC 2010 i686 i686 i386 GNU/Linux


How reproducible:
100%

Steps to Reproduce:
1. get an external monitor
2. attach it
  
Actual results:
I see gdm on both screens.

Expected results:
I keep my desktop and it is expanded to the other screen.
Comment 1 Felix Möller 2010-04-27 08:42:41 EDT
Created attachment 409465 [details]
log of the xserver when attaching a screen

The last line is:
[  9689.186] (II) intel(0): Allocate new frame buffer 3120x1050 stride 3200
Comment 2 Felix Möller 2010-04-27 08:46:23 EDT
The hardware as returned by lspci -nn

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
Comment 3 Adam Williamson 2010-04-27 08:53:45 EDT
Thanks for the report.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Felix Möller 2010-05-20 14:30:40 EDT
It somehow changed. I do not get the login screen anymore but the screen goes just black. I can still move the mouse and change to tty2. Killing X gives me a display again.

Will attach a new log shortly. I would certainly appreciate some help, what to try and provide...
Comment 5 Felix Möller 2010-05-20 14:31:24 EDT
Created attachment 415488 [details]
Xorg.0.log when display goes black
Comment 6 Felix Möller 2010-05-31 03:13:01 EDT
Ok, I have found out with the help of nickle in the #intel-gfx channel on freenode that this is a problem of compiz.

Exchanging compiz with metacity solved the problem for me.

According to #intel-gfx compiz seems "not to respect the max renderbuf size"...
Comment 7 Felix Möller 2010-05-31 04:08:48 EDT
https://bugs.freedesktop.org/show_bug.cgi?id=22076 might be a related upstream bug.
Comment 8 Felix Möller 2010-07-28 10:43:50 EDT
This seems to be solved by intel 2.12 which i got from Koji. As I am on F14 now I cannot reproduce anymore.

Note You need to log in before you can comment on or make changes to this bug.